Timelion shows 0 count


I am trying to create a timelion in Kibana 4.5.

.es(logstash*) shows zero count. What will be the issue?

Do I need to change any settings?

the syntax is wrong

.es(query) ... so something like .es(*) should work
if you want to query specific index you need to pass it in as second parameter:
.es(*, index=logstash-*)

Thank You.

Finally fixed the issue. Used the syntax you mentioned & added 'timefield'.

right, if your timefield is not @timestamp (which is set as default) you'll need to set that as well.
.es(*, index=logstash-*, timefield=timestamp, metric=sum:bytes)

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.