@timestamp not appearing for a particular index in kibana

I created an index in elastic search with few fields and when i try to get this index in kibana (through setting, time based index events) , I can't see @timestamp field appearing in the fields dropdown. I do have other indexes in same elasticsearch for which same field is appearing.

Do I need to change anything specific to an index for this ?

Thank you.

Hi @gsb,

I assume the indexed documents contain a @timestamp field? If so, they should be assigned the date type in the mapping. You can check the mapping of your index by querying ${INDEX_NAME}/_mapping using the Dev Tools Console or any other HTTP client.

Hi @weltenwort No I haven't added @timestamp field explicitly and I don't have any date related field in schema/metadata. if that's blocking , How can I use this index in kibana ?


> Make sure the Index contains time-based events box is unchecked when you create index patterns for these data sets.

You can use the index without any date-related fields by unchecking the "Index contains time-based events" checkbox when creating the index pattern.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.