Trouble configuring Gmail SMTP with Watcher

alerting

(chantalle) #1

I have been going in circles for the past few hours trying to set up alerting with Watcher in Elasticsearch. I would greatly appreciate if someone could help me troubleshoot. There is an error at the time that Elasticsearch tries to send an email through Google's SMTP server. I am seeing this in the watch execution output:
Couldn't connect to host, port: smtp.gmail.com, 587; timeout 120000

Here is my Elasticsearch configuration:

Here is my watch:

Here is the error output when the action fails:

Here is what I've already tried:

  • Disabling firewall, this is not the issue
  • Changing the Gmail account settings to allow less secure applications to access my account
  • Enabling IMAP access on my Gmail account
  • Reading Google's authentication requirements for SMTP See (Gmail SMTP server) column
  • Creating an App password for my Google account and using it in the smtp.password field

All of the things I've tried result in the same error (connection failure)
Maybe I need to add additional settings in elasticsearch.yml for SSL?


(Steve) #2

I had something similar but it seems we cannot use outside SMTP server's now.

https://www.elastic.co/guide/en/cloud/current/ec-watcher.html#ec-watcher-whitelist


(chantalle) #3

So, it looks like now there is only support to send email notifications through the Elasticsearch Service?


(Steve) #4

Here is some of the info you are looking for on my post.