Issues configuring Kibana Watcher SMTP Server

Like the ones before me, I've been running in circles for the last few days haha.
When I modify the user settings with my SMTP server (SendGrid) in the elastic.yml file, I get a "this changes are not allowed".
I don't know if my settings are wrong or that feature is deprecated.
I've followed all the available documentation but nothing. (xpack-watcher.actions, etc).

I also found this related topic:

My question is if the automatic monitoring email service via SMTP is deprecated? or maybe my elastic cloud deployment is not compatible (v7.13.3) ?

Thanks in advance!

Can you give me the exact setting name you're trying to set in Cloud? If I know the setting I can try to figure out what's going on.


Hi Oleg!
I was using this config:
    profile: sendgrid
      auth: true
      starttls.enable: true
      port: 587
      apikey: ******
      password: ***********

I've also tried xpack. instead of watcher.actions.
Hope you can help me figure this out.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.