Trouble installing Elasticsearch plugin


(Vilas Reddy Podduturi) #1

Hi,

Everytime I try to install plugin from zip file, it fails with different errors.
So, I manually extract plugin to plugins folder.

I am trying to use readonlyrest plugin: https://github.com/sscarduzio/elasticsearch-readonlyrest-plugin
But I get following error:


C:\Tools\elasticsearch-1.5.2>bin\plugin.bat --url file://C:\PVR\Downloads\elasticsearch-readonlyrest-v1.3_es-v1.5.2.zip --install readonlyrest
-> Installing readonlyrest...
Trying file://C:/PVR/Downloads/elasticsearch-readonlyrest-v1.3_es-v1.5.2.zip...
Failed: UnknownHostException[C]
Trying https://github.com/null/readonlyrest/archive/master.zip...
Failed to install readonlyrest, reason: failed to download out of all possible locations..., use --verbose to get detailed information

Request you to please suggest how to resolve this.

Or any manual method to install it.

Thanks.


(David Pilato) #2

Try:

bin\plugin.bat --url file:/PVR/Downloads/elasticsearch-readonlyrest-v1.3_es-v1.5.2.zip --install readonlyrest

If not working, create a plugins/readonlyrest dir in your es dir and unzip the zip content there.


(Vilas Reddy Podduturi) #3

Thanks @dadoonet The command worked.

But when I start the Elasticsearch now, I get the following error.

{1.5.2}: Initialization Failed ...
1) NoSuchMethodError[org.elasticsearch.rest.BaseRestHandler.<init>(Lorg/elasticsearch/common/settings/Settings;Lorg/elasticsearch/client/Client;)V]

I assume this plugin is causing some issue. Any suggestions.


(David Pilato) #4

Might not be compatible with this version...


(Vilas Reddy Podduturi) #5

Yes. It seems so.
Plugin is available for different versions. 1.5.x plugin version failed with Elasticsearch 1.5.2

But the 1.4.x plugin version worked with Elasticsearch 1.4.1

I wonder if others facing the issue with 1.5.x plugin too.


(system) #6