Trying to open a dashboard: Visualize: Request Timeout after 30000ms


#1

Hello..
I 'am running Elasticsearch, Kibana and Logstach 5.2.2 in a Docker environment. Comming back from holiday I tried to open a saved dashboard that I know is working.

After 30 seconds of loading, Kibana respond with:

Visualize: Request Timeout after 30000ms

I tried to reboot the linux box, but same result :frowning:


(Christian Dahlqvist) #2

That typically means Elasticsearch is slow responding. What is the specification of your Elasticsearch cluster? Which version are you running? How much data/indices/shards do you have in the cluster?


#3

Hi,,
Kibana, Logstash and ES is running on the same Vmware image (CentOS7). Three different Docker containers.
We have added three new FileBeat clients lately, so that can be the reason for slow response. A total of 10 clients.

I am a bit new to ES, Kibana and Logstash, but I'am learning fast :slight_smile: We are running 5.2.2 of the ES suite.

Here is some stats:

shards: 691
heap.percent: 92
ram.percent: 94
cpu: 20
heap total (MB): 71.24
heap used(MB): 61.58
indices: 140

Hope this helps..


#4

The server had only 8GB ram. I increased the memory to 16GB. That solved the problem. It was swapping too much.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.