Unable to add cross-cluster index pattern

Hello,

I set up two Elasticsearch clusters (cluster_a, cluster_b) and I was able to set cluster_a as a remote cluster on cluster_b and vice versa.

Using the dev CLI feature, I am also able to query indexes of cluster_a from cluster_b and vice versa.

However, when I try to add cluster_a's indexes to cluster_b, I get the error "Failed to Load Indexes". This happens in the other direction as well.

Does anyone know what could be causing this error and some methods to resolve it? I know for sure that they are connected since I am able to query the indexes from the dev CLI and I see the green check mark on the Remote Index UI. I checked in the network tab on the browser and no errors appeared as well.

Any ideas are appreciated.

Thank you

Are you trying to create an index pattern? If so, then the format you'll use for the pattern itself should be something like this:

cluster_name:index_name

Please let me know if that works for you.

That worked perfectly! Before I was using cluster_name:*, but using the format you suggested worked on both clusters.

Thank you!