Unable to connect Kibana on 5601


(Carlos Andres Zambrano Barrera) #1

I am installing elasticsearch and kibana on EC2 aws, currently following this steps https://www.elastic.co/blog/running-elasticsearch-on-aws, I am trying with 5.6.3 elastic search and it is installed. Both services are running but when i tried to access by webbrowser it does not load
http://54.89.173.143:5601/

KIBANA PORT
[ec2-user@ip-10-4-0-107 kibana]$ curl http://localhost:5601

ELASTICSEARCH PORT
}[ec2-user@ip-10-4-0-107 kibana]$ curl http://localhost:9200{ "name" : "h91YN9J", "cluster_name" : "elasticsearch", "cluster_uuid" : "QffVAwnzQVWVywehVMYSKA", "version" : { "number" : "5.6.3", "build_hash" : "1a2f265", "build_date" : "2017-10-06T20:33:39.012Z", "build_snapshot" : false, "lucene_version" : "6.6.1" }, "tagline" : "You Know, for Search"}


(Matt Bargar) #2

What host have you specified for server.host in kibana.yml? If you haven't bound to a public interface you won't be able to access Kibana from outside the host machine.


(Carlos Andres Zambrano Barrera) #3

in kibana.yml server.host: "localhost"
the elasticsearch and the kibana are on the same server


(Matt Bargar) #4

Try setting server.host to the ip that you're trying to access in your web browser.


(Carlos Andres Zambrano Barrera) #5

server.host: "54.89.173.143"

I have tried leave in 0.0.0.0 and restart the service and does not work, also i attached a domain and does not load the page of kibana.


(Matt Bargar) #6

Can you access Kibana from the machine it's running on? Anything in the Kibana logs?


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.