Kibana is not accessible from external browser


I am trying to install Elasticsearch and Kibana on Debian 10. they both work and active in the current machine. I want to access Kibana through different machine's browser, but it cannot be reached.

I have changed Kibana.yml configuration,
server.port: 5601 "IP" - my IP address
elasticsearch.hosts: ["http://IP:9200"]

Also, I have enabled 5601 and 9200 ports through he firewall by using UFW commands.

even though, still not working. Any idea how to fix that??


Hi @almotasim90 ,

Maybe you're not using the right network interface. Does it work if you specify


Hi Oleg,

No, it did not work with "", as a server host.

I am not sure what else to try!!

Would it be possible to enable logging in UFW (or maybe temporarily disable it), just to check if requests reach your host at all?

I have tried that, it is not working. The thing is if ping the machine ip address from outside it is active. also with port 80. But when I ping with 5601 port it is not reachable.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.