Unable to connect to elasticsearch after upgrading to 7.3.0

I upgraded to elastisearch 7.3.0 on Windows and the service is running. With the default elasticsearch.yml, I am able to connect to localhost:9200 but I cannot connect to it with IpAddress:9200 on the local machine or from another machine. It does not work even after I added network.host: to elasticsearch.yml. I also tried to add network.publish_host: IpAddress but it did not work either.

I am on Windows Server 2012 R2 Standard

Update: The elasticsearch-service-x64 service dies once I have network.host: (or the server's IP address). I can start/restart it but after several seconds, it just dies.

Update 2: After uinstalling the service, making sure service with that service id is completely removed, re-installing the service, the service now can stay alive. But still "network.host:" does not work for me. Without it, I can do "localhost:9200" but with it I can neither do "IpAddress:9200" nor do "localhost:9200".

Hello @jxz,

can i have more details, Logs and your conf.yml ??


I am facing the same problem, please, help.

I have just added a single line with the default configuration: network.host:

I have raised the issue here as well: Network.host: is not working in elasticsearch 7.3.0

Please, help.

Hi, got it.

Added this line to the elasticsearch.yml file and problem is solved: cluster.initial_master_nodes: node-1

For the sake of other readers, this isn't necessarily the right fix. You must look at the logs from Elasticsearch to determine why it's not starting up properly. If the right fix is to set cluster.initial_master_nodes then you will likely see a log message indicating as such. Otherwise it's something else.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.