Unable to find elasticsearch, logstash, kibana metrics on stackmonitoring even after having all the .monitoring-* indices created and the Cluster_uuid is right

Unable to find elasticsearch, logstash, kibana metrics on stackmonitoring even after having all the .monitoring-* indices created and the Cluster_uuid is right.

What version are you on?
How did you configure the monitoring?

metricbeat, filebeat: 7.9.1
Logstash, elasticsearch, kibana: 7.10.2

Yes, I have set the monitoring parameters in metricbeat.yml

The issues is that I see a "standalone Cluster" on stack monitoring page listing only beats and not elasticsearch, Kibana and logstash separately.
On the metricbeat we are sending data to redis output and not to elasticsearch directly. Metricbeat --> Redis --> Logstash --> Elasticsearch.

Filebeat on other hand is creating .monitoring-beats-* index but the type: index_stats has cluster_uuid as null and type: index_state has the right cluster_uuid.

Please use the same version across the stack. Not sure if that's the problem though.

That's probably the problem. You need to share the metricbeat.yml configuration.

I'm moving your question to #elastic-stack:beats with the #metricbeat tag.

Did you get an alert when you posted that message that it was badly formatted?

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:

```
CODE
```

This is the icon to use if you are not using markdown format:

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.
Please update your post.

Sorry about that. Here is the formatted one.
    indent preformatted text by 4 spaces
metricbeat.yml:
########################## Metricbeat Configuration ###########################

    #========================== Modules configuration ============================

    metricbeat.modules:

    * module: nginx

    metricsets:

    * stubstatus

    period: 1m

    hosts: ["[http://127.0.0.1:8080](http://127.0.0.1:8080/)"]

    server_status_path: "nginx_status"

    * module: redis

    metricsets:

    * info
    * keyspace

    period: 1m

    hosts: ["127.0.0.1:6379"]

    #- module: system

    [#period](javascript:void(0);): 2m

    [#metricsets](javascript:void(0);):

    #- cpu

    #- load

    #- memory

    #- network

    #- process

    #- process_summary

    #- socket_summary

    #- core

    #- diskio

    #- socket

    [#process](javascript:void(0);).include_top_n:

    [#by_cpu](javascript:void(0);): 5 # include top 5 processes by CPU

    [#by_memory](javascript:void(0);): 5 # include top 5 processes by memory

    #- module: system

    [#period](javascript:void(0);): 5m

    [#metricsets](javascript:void(0);):

    # - filesystem

    # - fsstat

    [#processors](javascript:void(0);):

    #- drop_event.when.regexp:

    # system.filesystem.mount_point: '^/(sys|cgroup|proc|dev|etc|host|lib)($|/)'

    #- module: system

    [#period](javascript:void(0);): 15m

    [#metricsets](javascript:void(0);):

    #- uptime

    * module: rabbitmq

    metricsets:

    * node
    * queue
    * connection
    * exchange

    period: 30s

    hosts: ["localhost:15672"]

    username: "XXXXXX"

    password: "XXXXXX"

    * module: elasticsearch

    metricsets:

    * ccr
    * cluster_stats
    * enrich
    * index
    * index_recovery
    * index_summary
    * ml_job
    * node_stats
    * shard

    period: 10s

    hosts: [ "https://jhskjhs.jskjhksh.ljhgss:9200" ]

    username: "XXXXXX"

    password: "XXXXXX"

    xpack.enabled: true

    * module: logstash

    metricsets:

    * node
    * node_stats

    period: 10s

    hosts: ["jkhskjsh.jsjkhskhjks.kshkshjs:9600"]

    username: "XXXXXX"

    password: "XXXXXX"

    xpack.enabled: true

    #- module: beat

    [#metricsets](javascript:void(0);):

    #-stats

    # -state

    [#period](javascript:void(0);): 10s

    [#hosts](javascript:void(0);): ["[https://127.0.0.1:5044](https://127.0.0.1:5044/)"] [#not](javascript:void(0):wink: working with 5044, 5066

    [#username](javascript:void(0);): "XXXXXX"

    [#password](javascript:void(0);): "XXXXXX"

    [#xpack](javascript:void(0);).enabled: true

    * module: kibana

    metricsets: ["status"]

    period: 10s

    hosts: ["[https://127.0.0.1:5601](https://127.0.0.1:5601/)"]

    username: "XXXXXX"

    password: "XXXXXX"

    basepath: ""

    enabled: true

    xpack.enabled: true

    #==================== Elasticsearch template setting ==========================

    setup.template.settings:

    index.number_of_shards: 1

    index.codec: best_compression

    #_source.enabled: false

    #================================ General =====================================

    fields:

    labels:

    env: "test"

    hostname: "uk-telk01"

    fields_under_root: true

    #============================== Kibana =====================================

    setup.kibana:

    host: "[https://uk-telk01.wintech.local:443](https://uk-telk01.wintech.local/)"

    #================================ Outputs =====================================

    #------------------------------- Redis output ----------------------------------

    output.redis:

    hosts: [ "uk-telk01.wintech.local", "uk-telk01.wintech.local" ]

    key: "log.beats"

    #================================ Processors =====================================

    processors:

    * add_host_metadata: ~
    * add_locale: ~

    #================================ Logging =====================================

    [#logging](javascript:void(0);).level: debug

    [#logging](javascript:void(0);).selectors: ["*"]

    logging.metrics.period: 5m

    #============================== Xpack Monitoring ===============================

    [#xpack](javascript:void(0);).monitoring.enabled: true

    [#xpack](javascript:void(0);).monitoring.elasticsearch:

    [#hosts](javascript:void(0);): [ "[https://uk-telk01.wintech.local:9200](https://uk-telk01.wintech.local:9200/)" ]

    [#username](javascript:void(0);): "remote_monitoring_user_test"

    [#password](javascript:void(0);): "Test@12345"

    [#username](javascript:void(0);): "XXXXXX"

    [#password](javascript:void(0);): "XXXXXX"

    monitoring.enabled: true

    monitoring.elasticsearch:

    hosts: [ "[https://uk-telk01.wintech.local:9200](https://uk-telk01.wintech.local:9200/)" ]

    username: "XXXXXX"

    password: "XXXXXX"

    [#monitoring](javascript:void(0);).cluster_uuid: "lFddVQtUSAyl6o3nIeupBs" --> when set metricbeat stops sending monitoring data to monitoring cluster