Unicast discovery options?


(project2501) #1

Hi,
I've hunted through the guides and group but can't seem to get
unicast discovery to work.

I run ES on one server with no options.

On a second server I run:
bin/elasticsearch -Ddiscovery.zen.ping.unicast.enabled=true -
Ddiscovery.zen.ping.unicast.hosts=["192.168.0.7"]

Is this right?
I get various results. Sometimes exception in the master log.
Sometimes nothing at all.

thanks!


(Shay Banon) #2

You need to prefix the settings if provided using -D using es, for example, -Des.discovery.zen.ping…. . I don't know where you found the unicast.enabled flag in the docs… . Here are the settings to configure unicast: https://github.com/elasticsearch/elasticsearch/blob/master/config/elasticsearch.yml#L313.

On Sunday, February 26, 2012 at 6:54 PM, project2501 wrote:

Hi,
I've hunted through the guides and group but can't seem to get
unicast discovery to work.

I run ES on one server with no options.

On a second server I run:
bin/elasticsearch -Ddiscovery.zen.ping.unicast.enabled=true -
Ddiscovery.zen.ping.unicast.hosts=["192.168.0.7"]

Is this right?
I get various results. Sometimes exception in the master log.
Sometimes nothing at all.

thanks!


(project2501) #3

Thanks for the quick reply Shay. It works now.

Oh, I guess I 'made up' the unicast.enabled property. Probably deduced
it. Silly me.

On Feb 26, 2:52 pm, Shay Banon kim...@gmail.com wrote:

You need to prefix the settings if provided using -D using es, for example, -Des.discovery.zen.ping…. . I don't know where you found the unicast.enabled flag in the docs… . Here are the settings to configure unicast:https://github.com/elasticsearch/elasticsearch/blob/master/config/ela....

On Sunday, February 26, 2012 at 6:54 PM, project2501 wrote:

Hi,
I've hunted through the guides and group but can't seem to get
unicast discovery to work.

I run ES on one server with no options.

On a second server I run:
bin/elasticsearch -Ddiscovery.zen.ping.unicast.enabled=true -
Ddiscovery.zen.ping.unicast.hosts=["192.168.0.7"]

Is this right?
I get various results. Sometimes exception in the master log.
Sometimes nothing at all.

thanks!


(Shay Banon) #4

Cool :slight_smile:

On Sunday, February 26, 2012 at 10:10 PM, project2501 wrote:

Thanks for the quick reply Shay. It works now.

Oh, I guess I 'made up' the unicast.enabled property. Probably deduced
it. Silly me.

On Feb 26, 2:52 pm, Shay Banon <kim...@gmail.com (http://gmail.com)> wrote:

You need to prefix the settings if provided using -D using es, for example, -Des.discovery.zen.ping…. . I don't know where you found the unicast.enabled flag in the docs… . Here are the settings to configure unicast:https://github.com/elasticsearch/elasticsearch/blob/master/config/ela....

On Sunday, February 26, 2012 at 6:54 PM, project2501 wrote:

Hi,
I've hunted through the guides and group but can't seem to get
unicast discovery to work.

I run ES on one server with no options.

On a second server I run:
bin/elasticsearch -Ddiscovery.zen.ping.unicast.enabled=true -
Ddiscovery.zen.ping.unicast.hosts=["192.168.0.7"]

Is this right?
I get various results. Sometimes exception in the master log.
Sometimes nothing at all.

thanks!


(system) #5