Unsupported config option for services.elastic-1: 'processors'

I'm setting up three nodes in a docker compose file to run on a single (beefy) host. I'm following the practices outlined in the following places:

Below is the snippet of my docker compose file causing me issues.


version: '2'
services:
elastic-1:
image: "Elasticsearch:latest"
restart: "always"
networks:
- elastic-backend
ports:
- "9200:9200"
volumes:
- "PPINSTALLPP/var/elastic:/usr/share/Elasticsearch/data/node1"
environment:
- "ES_JAVA_OPTS=-Xms2G -Xmx2G"
- cluster.name=Elasticsearch
- node.name=elastic-1
- xpack.security.enabled=false

  # This option keeps JVM memory from being paged out to swap
  - bootstrap.memory_lock=true

  - discovery.zen.ping.multicast.enabled=false
  - discovery.zen.ping.unicast.hosts="elastic-2","elastic-3"

ulimits:
  memlock:
    soft: -1
    hard: -1

# This caps the amount of memory available to the container
mem_limit: 2g

processors: 2

Note: I've tuned the resources way down just for testing.

I want to set the number of processors so I don't have all three instances competing on the same processors. I receive the following error:

Unsupported config option for services.elastic-1: 'processors'

I'm not sure what I'm missing. Any ideas?

Bump - does the processors option no longer work?

I figured it out. You have to put it under the environment header like:

elastic-#:
....
environment:
- processors=2
...

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.