Update Failed, Internal Server Error


(Tempy McTempFace) #1

Trying to update Ubuntu and the Elastic Stack (Debian Package) I get Internal Server Error.
When I run "apt-get update && apt-get dist-upgrade" my server tries to reach those links for example:
https://artifacts.elastic.co/packages/6.x/apt stable/main amd64 heartbeat-elastic amd64 6.3.1
https://artifacts.elastic.co/packages/6.x/apt stable/main amd64 kibana amd64 6.3.1
Then I get the following message:
500 Internal Server Error [IP: 23.21.67.46 443]

Or like this:

Ign:7 https://artifacts.elastic.co/packages/6.x/apt stable InRelease
Fehl:8 https://artifacts.elastic.co/packages/6.x/apt stable Release
500 Internal Server Error [IP: 107.21.253.15 443]

To me it looks like the links are not read correctly? This IP points to the Elastic website which is reachable, I'm not sure why it doesn't download the package.
When I installed the Elastic Stack I followed the documentation like:
wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add -
echo "deb https://artifacts.elastic.co/packages/6.x/apt stable main" | sudo tee -a /etc/apt/sources.list.d/elastic-6.x.list
This worked for me with the release 6.2.4.


(Martinrw) #2

I'm getting the same issue but for the CentOS repo.

I've reported it through my support contract but no updates just yet


(Martinrw) #3

Support got back to me and they were aware of the issue.
They've moved to another server but it looks like it's being hit hard so my downloads are timing out, probably because everyone is suddenly downloading again.

My suggestion is to wait a while and come back later


(Tempy McTempFace) #4

Thanks for letting me know.
Then I will update another day :slight_smile:


(Bas van Berckel) #5

It seems fixed now, I was just able to successfully get the packages.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.