Update logstash to specific version


I'm upgrading my stack from 7.9.3 to 7.12.1 using yum.

For elasticsearch and filebeat I can update for the specific version without any problem using:

yum install filebeat-7.12.1
yum install elasticsearch-7.12.1

But for logstash this does not work, when I try to set an specific version it returns Nothing to do.

If I do not specify the version it will work as expected:

Resolving Dependencies
--> Running transaction check
---> Package logstash.noarch 1:7.9.3-1 will be updated
---> Package logstash.x86_64 1:7.13.0-1 will be an update

With yum --show-duplicates list logstash I can see that the 7.12.1 package exists in the repository.

logstash.x86_64   1:7.12.1-1

But I did not find a way to update to this specific version from the repository.

I saw that from version 7.9 to 7.10 the name changed from logstash.noarch to logstash.x86_64, I tried to specify the arch in the yum, but no success.

I tried using install-nevra, no luck.

yum install-nevra logstash-1:7.12.1-1.x86_64

Is there any trick to update to this specific version using yum?

At this moment I'm download the rpm and using yum localinstall but this broke the automated process.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.