Upgraded Kibana from 7.12 to 7.14 and now it's broken

Bottom line up front: I’ve broken my Kibana by attempting an upgrade from 7.12 to 7.14.

Details:

We have an Elastic Stack installation in a development sandbox environment. The first version of the Stack components installed in this enclave was 7.12, and I’ve been working in this enclave on a migration plan to take our production enclaves to 7.14. I read the suggested order for doing upgrades and started with the Elasticsearch nodes. 7.14 installed just fine on those, I restarted each, the cluster is happy and responding to curl from the command line.

I then moved to the Kibana node, and I naively did not read any of the other migration instructions. I’ve done upgrades in other test environments from, for example, 6.8 to 7.3 by simply stopping Kibana, installing the new version, and then restarting Kibana, and magically everything works. No such luck this time. The installation apparently went OK, though I did get a non-fatal squawk about the location of the keystore file, but there is no joy in trying to access the Kibana web page.

Instead I’m getting a page saying “Something went wrong Try refreshing the page. If that doesn’t work, go back to the previous page or clear your session data.” Refreshing the page and clearing the session doesn't change the response, which is a pinkish-bordered box with red text “kbnBundles does not have a module defined for “plugin/data/public””. Inside the border is the following:

Verion: 7.14.0

Build: 42747

Error: kbnBundles does not have a module defined for “plugin/data/public”

get@https://172.31.52.56:5601/bootstrap.js:22:13

@https://172.31.52.56:5601/42747/bundles/plugin/esUiShared/kibana/esUiShared.plugin.js:1:31672

webpack_require@https://172.31.52.56:5601/42747/bundles/plugin/esUiShared/kibana/esUiShared.plugin.js:1:84761

.

.

(ten lines similar to the “@https” and “__webpack” lines above)

.

.

get@https://172.31.52.56:5601/bootstrap.js:25:12

createPluginInstance/instance<@https://172.31.52.56:5601/42747/bundles/core/core.entry.js:13:229435

createPluginInstance@https://172.31.52.56:5601/42747/bundles/core/core.entry.js:13:229211

setup@https://172.31.52.56:5601/42747/bundles/core/core.entry.js:13:228430

setup@https://172.31.52.56:5601/42747/bundles/core/core.entry.js:13:232591

setup@https://172.31.52.56:5601/42747/bundles/core/core.entry.js:13:276691

I’ve restarted the Kibana node, and cleared my web browser (Firefox) cache. I haven’t installed any plugins, at least not as far as I know. Obviously Kibana is running, but not responding correctly. Any suggestions for troubleshooting would be appreciated.

Bob

1 Like

Hello @RLPowellJr

How are you running Kibana? Do you see any errors in the logs?

what is your config file looks like in kibana?
There are some changes in 7.14 I believe that will stop kibana to start (if you have old setting)

server.port: 5601
server.host: "eskib.bob.com"
server.name: "Kibana Bob"
elasticsearch.hosts: https://es1.bob.com:9200
elasticsearch.username: "elastic"
server.ssl.enabled: true
server.ssl.certificate: "/etc/kibana/certs/eskib.bob.com.crt"
server.ssl.key: "/etc/kibana/certs/eskib.bob.com.key"
elasticsearch.ssl.certificate: "/etc/kibana/certs/eskib.bob.com.crt"
elasticsearch.ssl.key: "/etc/kibana/certs/eskib.bob.com.key"
elasticsearch.ssl.certificateAuthorities: [ "/etc/kibana/certs/ca.crt" ]
elasticsearch.ssl.verificationMode: none
xpack.security.audit.enabled: true
xpack.monitoring.enabled: true
xpack.monitoring.ui.enabled: true
elasticsearch.logQueries: true
logging.dest: /var/log/kibana/kibana.log

few thing to note here.
7.14
logging.dest is change to something else.
also elastisearch.logqueries syntax has changed
everything else looks correct. but I didn't see the elasticserarch.password entry here.

Running into the same issues here.

The error only shows when using safari Version 13.1.3 (15609.4.1).
Kibana is still working on chrome and safari Version 14.1.2 (16611.3.10.1.6).

Clearing session or incognito do not seem to solve the problem.

Changing the old logging.dest or Elasticsearch.logQueries settings do not solve the problem either.

when I upgraded 7.10.1 to 7.14 I had lot of problem.
journalctl -xe and/or log file will tell you what is going on. turn on debug mode that might help

I've gone back to Kibana 7.12. It seems to work just fine with Elasticsearch nodes at 7.14, so I'm going to work with that for the time being. In our environment changing browsers isn't an option (we're running Red Hat 7.6, with GNOME and Firefox on the GUI-equipped systems). I'll try the installation on another system that has never had Kibana and see what happens.

I tried commenting out the logging.dest and elasticsearch.logqueries lines entirely, with no change. The elasticsearch.password is in a keystore file. At some point I'm going to try installing Kibana on a system that's never had Kibana, configure for the bare minimum needed to talk to Elasticsearch, and see how that goes. I definitely appreciate the pointers given here, because "just Google that stuff" wasn't working!