Uptime does not display the details accurately


ELK 8.4.1 does not show correct details in uptime home.

The graph is blank and monitors does not show correct time.
But I can go through the monitor and check latest steps's data by clicking on next
Did any one faced this/know how to fix it?



Hi @swchandu sorry you're having some issues with Uptime. A few initial questions that might help us diagnose the problem:

  • Are using Logstash to ingest your data to Uptime?
  • Are you running an on-prem deployment, or using Elastic Cloud?
  • Are you able to see any errors in your browser's network tab or in the browser console?

I am using on-prem and no Logstash.
All the steps are running fine. it is only not being displayed in the uptime app.
If I am going through the monitor instance, It is providing the next to view latest details.
But the issue is with the uptime home page which does nto show correct details.

Thanks for confirming those details. How are your monitors defined and managed? Are you using Monitor Management in the Uptime UI, Fleet, local config with Heartbeat/Docker, etc.?

I am using heartbeat 8.4.1 docker container and monitors are written in playwright inline steps on local heartbeat.yml. This is directly connecting to elasticsearch 8.4.1 (docker version)
Fleet not used.

I think this can happens if there is clock difference between where your heartbeat is running vs kibana machine? Can you please make sure those are in sync. we are trying to investigate if it could be something else.

1 Like

As @shahzad31 mentioned - if the system clocks are too far out of sync between the HB container and Kibana/ES server it can cause some of the queries to not work properly, which could be the reason you're not seeing anything in the histogram (and perhaps incorrect time on the monitors you are seeing).

I've verified the histogram worked using a basic config like the one below against ES 8.4.1 and the matching Heartbeat Docker image. It does not seem like a configuration issue is the cause of your problem though, as most of the functionality is working.

  username: elastic
  password: changeme
  hosts: ['http://host.docker.internal:9200']
- type: browser
  id: synthetic-inline-tests
  name: Elastic website
  schedule: '@every 1m'
      script: |-
        step("load homepage", async () => {
          await page.goto('https://www.elastic.co');
        step("hover over products menu", async () => {
          await page.hover('css=[data-nav-item=products]');

You are right. I have just noticed that heartbeat's server time is ahead. I have fixed it. However, the same issue continues.

Hi @swchandu - are you still facing this problem?

One other thing worth trying here would be to stop Heartbeat and either:

  • delete the index
  • configure Heartbeat to write to a new index

Then, restart the agent. If you configured it to write to a new index, make sure you update the pattern in Uptime settings. It's possible that the mapping could be incorrect for your index, which has caused similar issues in the past.

Thanks. It worked

1 Like

This topic was automatically closed 24 days after the last reply. New replies are no longer allowed.