"Values less than 1 cannot be displayed on a log scale"


(red der) #1

Using Kibana version: 5.3.0

I have a percentile range bar graph using my "timetaken" field for the agg and I have configured the Y-Axis to be "log". Sometimes when I filter my events in kibana when using this visualization I get the error "Values less than 1 cannot be displayed on a log scale".

So this must mean that some of my filters are returning events where the timetaken field is less than 1.

So tried doing this search in the kibana search bar "timetaken: [1 TO *]" and then used one of my filters that was causing this error and it still says "Values less than 1 cannot be displayed on a log scale". How can this be? I'm returning all events where this field is equal to or greater than 1.

here is my query for the bar chart visualization:
{
"query": {
"bool": {
"must": [
{
"query_string": {
"query": "",
"analyze_wildcard": true
}
},
{
"match": {
"serverName.keyword": {
"query": "MYSERVER",
"type": "phrase"
}
}
},
{
"query_string": {
"analyze_wildcard": true,
"query": "
"
}
},
{
"range": {
"@timestamp": {
"gte": 1495574599798,
"lte": 1495660999798,
"format": "epoch_millis"
}
}
}
],
"must_not": []
}
},
"size": 0,
"_source": {
"excludes": []
},
"aggs": {
"2": {
"date_histogram": {
"field": "@timestamp",
"interval": "10m",
"time_zone": "America/New_York",
"min_doc_count": 1
},
"aggs": {
"1": {
"percentiles": {
"field": "timetaken",
"percents": [
25,
50,
75,
95,
99
],
"keyed": false
}
}
}
}
}
}


(Lee Drengenberg) #2

Hi Red,

Do you see a place in the options where you can set the min value on the y-axis like this?

This might depend on which version of Kibana you're on.

Regards,
Lee


(Lee Drengenberg) #3

Scratch that. I reproduced your issue. Looks like it might be a bug. I'll investigate further and then file an issue on it.


(red der) #4

Hey thanks! Edited my post to add the version Im on.

This is what I see for the Y-Axis:

I also tried to add this in "JSON Input" field but I must have the syntax wrong.
{ "script" : "doc['timetaken'].value > 1" }

I get this error:
"Visualize: class_cast_exception: null class_cast_exception: java.lang.Boolean cannot be cast to java.lang.Number"

The timetaken field is a "long"


(Lee Drengenberg) #5

I filed this issue;

If you follow that all the way to the end, you'll see that I did eventually get it to work, but it was only by changing my interval to be very large (Daily in my case) so that no bars (time intervals) had any empty buckets. This might also work for you?

Regards,
Lee


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.