Visualization Editor: Request to Elasticsearch failed:


#1

Hi,

I am not able to save/overwrite Dashboards or visualisation.

I get:
Visualization Editor: Request to Elasticsearch failed: "Request Timeout after 30000ms"

I use Kibana: Version: 4.6.3 Build: 10154
Elasticsearch 2.4

{"type":"response","@timestamp":"2016-12-01T10:48:20Z","tags":[],"pid":24924,"method":"post","statusCode":409,"req":{"url":"/elasticsearch/.kibana/visualization/Average-system-load-across-all-systems?op_type=create","method":"post","headers":{"host":"host","content-type":"application/json;charset=utf-8","accept":"application/json, text/plain, */*","kbn-version":"4.6.3","referer":"http://host/app/kibana","accept-language":"de-CH","accept-encoding":"gzip, deflate","user-agent":"Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko","dnt":"1","cache-control":"no-cache","x-forwarded-for":"10.16.10.73","x-forwarded-host":"host","x-forwarded-server":"host","connection":"Keep-Alive","content-length":"453"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1","referer":"http://host/app/kibana"},"res":{"statusCode":409,"responseTime":7,"contentLength":9},"message":"POST /elasticsearch/.kibana/visualization/Average-system-load-across-all-systems?op_type=create 409 7ms - 9.0B"}
{"type":"response","@timestamp":"2016-12-01T10:48:20Z","tags":[],"pid":24924,"method":"head","statusCode":200,"req":{"url":"/elasticsearch","method":"head","headers":{"host":"host:80","user-agent":"Go-http-client/1.1","accept":"application/json","x-forwarded-for":"10.1.52.160","x-forwarded-host":"host:80","x-forwarded-server":"host","connection":"Keep-Alive"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1"},"res":{"statusCode":200,"responseTime":4,"contentLength":9},"message":"HEAD /elasticsearch 200 4ms - 9.0B"}
{"type":"response","@timestamp":"2016-12-01T10:48:20Z","tags":[],"pid":24924,"method":"post","statusCode":400,"req":{"url":"/elasticsearch/_bulk","method":"post","headers":{"host":"host:80","user-agent":"Go-http-client/1.1","accept":"application/json","accept-encoding":"gzip","x-forwarded-for":"10.1.52.160","x-forwarded-host":"host:80","x-forwarded-server":"host","connection":"Keep-Alive","content-length":"19062"},"remoteAddress":"127.0.0.1","userAgent":"127.0.0.1"},"res":{"statusCode":400,"responseTime":3,"contentLength":9},"message":"POST /elasticsearch/_bulk 400 3ms - 9.0B"}

I have a Apache running which will listen on port 80 and direct it to port 5601.

Elasticsearch is also running on this machine.

Kibana.yml is default.

Why cant I overwrite objects?


(Lee Drengenberg) #2

Can you try accessing Kibana directly on port 5601 and see if it works OK in that case?


#3

This is not possible.

We have a apacheproxy running on the host.

Kibana and elasticsearch are on the same host
Port 80 redirects to port 5601
and port 80/elasticsearch is redirected to 9200

And the Kibana config uses the localhost to connect to elasticsearch.

I really dont know why those requests are not working. It´s like PUT and POST are blocked, but I can see some requests in the logs and they are working.


(Lee Drengenberg) #4

Are you using the apache proxy for authentication? There's some similar issues here;

Specifically a section like this;

<Limit POST PUT DELETE>
  Require valid-user
</Limit>

#5

Hi LeeDr,

we have accomplished the errors.

It was indeed the Apache.
We had to turn off those Settings.

    ProxyRequests Off
    ProxyErrorOverride Off

After that everything worked. I am not familiar with Apache so I just relay on the experience of my Co Worker.

Thank you for the hint with Apache Limits.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.