Watcher: [parse_exception] password is a required option when trying to call cluster status

alerting

(Ramesh Pendela) #1

Referring to below thread,

I am experiencing same issue, we allow only https communication.

here is my watcher call,

{
  "trigger": {
    "schedule": {
      "interval": "10s"
    }
  },
  "input": {
    "http": {
      "request": {
        "scheme": "https",
        "host": "my-ip",
        "port": 9200,
        "method": "get",
        "path": "/_cluster/health",
        "params": {},
        "headers": {},
        "auth": {
          "basic": {
            "username": "user",
            "Password": "user-password"
          }
        }
      }
    }
  },
  "condition": {
    "compare": {
      "ctx.payload.status": {
        "not_eq": "green"
      }
    }
  },
  "actions": {
    "send_email": {
      "email": {
        "profile": "standard",
        "to": [
          "user@domain.com"
        ],
        "subject": "Cluster Status Warning",
        "body": {
          "text": "Cluster status is RED/YELLOW"
        }
      }
    }
  }
}

Getting Watcher: [parse_exception] password is a required option

Along with that,

I have one more question, if I have multiple elastic-search nodes in my cluster and pointing to specific node, what if that node goes down?, How watcher call execute?


(Ramesh Pendela) #2

Can anyone help me hear?


(Alexander Reelsen) #3

have you tried password with a lowercase p instead of an upper case one?


(Ramesh Pendela) #4

@spinscale Thanks, that worked


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.