Watcher Service not working

I have a three node elasticsearch cluster, One node is not connecting to the cluster. The elasticsearch service running on it but i saw this error.

[2018-07-17T00:00:07,000][ERROR][o.e.x.w.e.ExecutionService] [elk-data-node02] failed to update watch record [arew575AS2mNXNz-uWcMvQ_elasticsearch_cluster_status_ded01a2a-e3dc-47a7-ac52-b7464f371248-2018-07-16T23:59:36.980Z]
org.elasticsearch.ElasticsearchTimeoutException: java.util.concurrent.TimeoutException: Timeout waiting for task.

I tried restarting the elasticsearch service but now i am getting this error.
[2018-07-17T00:00:07,000][ERROR][o.e.x.w.e.ExecutionService] [elk-data-node02] failed to update watch record [arew575AS2mNXNz-uWcMvQ_xpack_license_expiration_a2ee5443-eb6b-43eb-a88f-0028b0c606b7-2018-07-16T23:59:36.980Z]

[2018-07-17T00:00:22,493][ERROR][o.e.x.w.e.ExecutionService] [elk-data-node02] failed to update watch record [arew575AS2mNXNz-uWcMvQ_kibana_version_mismatch_e7b522b6-f232-45c9-b7d9-38113314eb83-2018-07-16T23:59:52.483Z]

I still have six days remaining in the xpack license. and all the nodes are running on elasticsearch-6.3.0

What do your logs look like for node02? Seems like you'd want to start with getting node02 connected back with the cluster.

Hi Thomas,

I am not seeing any other logs apart from the above logs. I tried to remove the watcher and restarted the elasticsearch, now i am not seeing any errors but its still not connecting to the cluster.

Sorry for the late response, your response email went to my spam folder :frowning: Any luck getting this resolved - i think at this point your trial license has expired so I hope you figured it out?

Concerning the logs, you can find Elasticsearch logs in /var/log/elasticsearch. If you view the log for node2 it should show you what happened to that particular node.

I restarted the whole cluster and removed the watcher which was giving me errors while starting it up. Thanks for the response :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.