Reporting / watcher - Request Timeout after 30000ms

Hi All,

I recently upgraded from ELK 6.2.4 to 6.5.3 and my watchers are getting a timeout error. We have platinum license install on this cluster.

The error I am getting in this one:

	"type": "error",
	"@timestamp": "2018-12-18T14:22:04Z",
	"tags": [],
	"pid": 981,
	"level": "error",
	"error": {
		"message": "Request Timeout after 30000ms",
		"name": "Error",
		"stack": "Error: Request Timeout after 30000ms\n    at /usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:355:15\n    at Timeout.<anonymous> (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:384:7)\n    at ontimeout (timers.js:498:11)\n    at tryOnTimeout (timers.js:323:5)\n    at Timer.listOnTimeout (timers.js:290:5)"
	"url": {
		"protocol": null,
		"slashes": null,
		"auth": null,
		"host": null,
		"port": null,
		"hostname": null,
		"hash": null,
		"search": "",
		"query": {},
		"pathname": "/api/watcher/watch/execute",
		"path": "/api/watcher/watch/execute",
		"href": "/api/watcher/watch/execute"
	"message": "Request Timeout after 30000ms"

My kibana config looks like this.

server.port: 5601
server.maxPayloadBytes: 1048576 "logweb2"
elasticsearch.preserveHost: true
kibana.index: ".kibana"
kibana.defaultAppId: "discover"
# This is not used YET!
elasticsearch.username: elastic
elasticsearch.password: changeme
xpack.monitoring.cluster_alerts.email_notifications.email_address: ''
# We do ssl offloading in the SLB. this should NOT be set.
server.ssl.enabled: false
server.ssl.certificate: /etc/kibana/certs/logweb2.crt
server.ssl.key: /etc/kibana/certs/logweb2.key
elasticsearch.ssl.certificate: /etc/kibana/certs/logweb2.crt
elasticsearch.ssl.key: /etc/kibana/certs/logweb2.key
elasticsearch.ssl.certificateAuthorities: [ "/etc/kibana/certs/ca.crt" ]
elasticsearch.ssl.verificationMode: certificate
#elasticsearch.requestHeadersWhitelist: [ authorization ]
#elasticsearch.customHeaders: {}
#elasticsearch.shardTimeout: 0
#elasticsearch.startupTimeout: 5000

#pid.file: /var/run/
logging.dest: /var/log/kibana/kibana.log
#logging.silent: false
#logging.quiet: false
#logging.verbose: false
#ops.interval: 5000

#i18n.defaultLocale: "en"
xpack.reporting.enabled: true
xpack.reporting.encryptionKey: thisIsAfakeKeyNotThatItMatters
#xpack.reporting.queue.timeout: 60000
xpack.reporting.kibanaServer.protocol: http

I am bit lost on how to continue.. Are there options I need / can set or did I forget something during the upgrade.

Any help would be appreciated..


I found a similar discuss post- may be it might help you narrow down the issue, if not, plz let us know.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.