Problem when creating index : Request Timeout after 30000ms


(Ankita Nema) #1

Hi

I get this error when I try to create a new index from kibana. (Management --> Index pattern--> Add new)
When I try to search for that index in Dev tools I could see it.

Request Timeout after 30000ms
Version: 5.2.1
Build: 14707
Error: Request Timeout after 30000ms
at http://172.19.172.220:30067/bundles/kibana.bundle.js?v=14707:14:8629
at http://172.19.172.220:30067/bundles/kibana.bundle.js?v=14707:14:9050

How do find the real cause of the issue & fix it ?


Timeout Errors when creating lots of new Indices?
(Ankita Nema) #2

elastic logs : [2017-08-02T08:51:18,356][WARN ][o.e.d.c.ParseField ] Deprecated field [type] used, replaced by [match_phrase and match_phrase_prefix query]
[2017-08-02T08:51:18,356][WARN ][o.e.d.c.ParseField ] Deprecated field [type] used, replaced by [match_phrase and match_phrase_prefix query]
[2017-08-02T08:51:18,356][WARN ][o.e.d.c.ParseField ] Deprecated field [type] used, replaced by [match_phrase and match_phrase_prefix query]
[2017-08-02T08:57:32,318][WARN ][o.e.l.LicenseService ] [r4K8HAF]

LICENSE [EXPIRED] ON [THURSDAY, APRIL 20, 2017]. IF YOU HAVE A NEW LICENSE, PLEASE UPDATE IT.
OTHERWISE, PLEASE REACH OUT TO YOUR SUPPORT CONTACT.

COMMERCIAL PLUGINS OPERATING WITH REDUCED FUNCTIONALITY

  • security
  • Cluster health, cluster stats and indices stats operations are blocked
  • All data operations (read and write) continue to work
  • watcher
  • PUT / GET watch APIs are disabled, DELETE watch API continues to work
  • Watches execute and write to the history
  • The actions of the watches don't execute
  • monitoring
  • The agent will stop collecting cluster and indices metrics
  • The agent will stop automatically cleaning indices older than [xpack.monitoring.history.duration]
  • graph
  • Graph explore APIs are disabled
    [2017-08-02T08:58:02,269][INFO ][o.e.m.j.JvmGcMonitorService] [r4K8HAF] [gc][8362403] overhead, spent [268ms] collecting in the last [1s]
    [2017-08-02T08:58:34,342][INFO ][o.e.m.j.JvmGcMonitorService] [r4K8HAF] [gc][8362435] overhead, spent [289ms] collecting in the last [1s]
    [2017-08-02T08:58:43,357][INFO ][o.e.m.j.JvmGcMonitorService] [r4K8HAF] [gc][8362444] overhead, spent [259ms] collecting in the last [1s]
    [2017-08-02T08:58:58,484][INFO ][o.e.m.j.JvmGcMonitorService] [r4K8HAF] [gc][8362459] overhead, spent [271ms] collecting in the last [1s]

(Ankita Nema) #3

kibana logs
{"type":"response","@timestamp":"2017-08-02T08:58:29Z","tags":[],"pid":7,"method":"get","statusCode":200,"req":{"url":"/elasticsearch/cncopy/mapping/field/*?=1501699349055&ignore_unavailable=false&allow_no_indices=false&include_defaults=true","method":"get","headers":{"host":"172.19.172.220:30067","connection":"keep-alive","accept":"application/json, text/plain, /","kbn-version":"5.2.1","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36","referer":"http://172.19.172.220:30067/app/kibana","accept-encoding":"gzip, deflate","accept-language":"en-US,en;q=0.8"},"remoteAddress":"10.244.0.0","userAgent":"10.244.0.0","referer":"http://172.19.172.220:30067/app/kibana"},"res":{"statusCode":200,"responseTime":30054,"contentLength":9},"message":"GET /elasticsearch/cncopy/mapping/field/*?=1501699349055&ignore_unavailable=false&allow_no_indices=false&include_defaults=true 200 30054ms - 9.0B"}
{"type":"log","@timestamp":"2017-08-02T08:59:25Z","tags":["status","plugin:elasticsearch@5.2.1","info"],"pid":7,"state":"green","message":"Status changed from red to green - Kibana index ready","prevState":"red","prevMsg":"Request Timeout after 30000ms"}
{"type":"log","@timestamp":"2017-08-02T08:59:25Z","tags":["status","ui settings","info"],"pid":7,"state":"green","message":"Status changed from red to green - Ready","prevState":"red","prevMsg":"Elasticsearch plugin is red"}
{"type":"log","@timestamp":"2017-08-02T08:59:25Z","tags":["status","plugin:xpack_main@5.2.1","info"],"pid":7,"state":"green","message":"Status changed from red to green - Ready","prevState":"red","prevMsg":"Request Timeout after 30000ms"}
{"type":"log","@timestamp":"2017-08-02T08:59:25Z","tags":["status","plugin:searchprofiler@5.2.1","info"],"pid":7,"state":"green","message":"Status changed from red to green - Ready","prevState":"red","prevMsg":"Request Timeout after 30000ms"}
{"type":"log","@timestamp":"2017-08-02T08:59:25Z","tags":["status","plugin:tilemap@5.2.1","info"],"pid":7,"state":"green","message":"Status changed from red to green - Ready","prevState":"red","prevMsg":"Request Timeout after 30000ms"}


(Lukas Olson) #4

Looks like your license has expired. Have you tried disabling x-pack and retrying?


(Ankita Nema) #5

X-pack is disabled from the start. I don't know why I see that in the message.

Could it be heap size problem?


(Lukas Olson) #6

It's possible it's a heap size problem... You could try increasing your heap size in jvm.options.

It's also possible it could be something else. Did you recently upgrade Kibana/Elasticsearch?


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.