What ES version we need to upgrade from 2.1

Could someone please help me to clarify what ES version to be upgraded from 2.1 which we are currently using ?

Since I see after 2.1 there are 2.4 and also 5.x series is started , why there is sudden jump from 2.4 to 5.x series ? are both 2.x and 5.x series should be picked for different use cases


We jumped v3 and 4 and aligned the stack at 5.0.

If you are looking to upgrade, we'd definitely recommend moving to the latest version - 5.3.0. But if you cannot make that move, go to 2.4.4.

Thank you

we are using Zookeeper, storm , Kafka and ES in the application. Planning to upgrade Zookeeper , Storm (may be Kafka as well) to the below listed latest versions , will those upgrade mandate to ES (currently we are using ES v 2.1) upgrade for integration ?

Currently we are using Zookeeper from 3.4.6 ; upgrade to 3.4.10
Kafka from upgrade to
Storm from 0.10.0 upgrade to 1.1.0

Dunno sorry.

NP, thanks

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.