When are mappings persisted?


(Oliver B. Fischer) #1

I have a bunch of scripts to setup my development and production system.
Now I recognized that ElasticSearch does not persist the configuration
of new indexes if I create the index and immediately shut down
ElasticSearch:

curl -X PUT http://localhost:9200/myindex -d @mapping.json
curl -X POST http://localhost:9200/_shutdown?pretty

If I wait around 20s between index creation and shutting down ES the
configuration will be saved.

So, that is fine for my production setup but not so fine for
development. Can I change this somehow?

Bye,

Oliver

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #2

Sending a refresh to "myindex" should work.

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Oliver B. Fischer) #3

No, same result. Index settings are not persisted.

Am 31.10.13 18:40, schrieb joergprante@gmail.com:

Sending a refresh to "myindex" should work.

Jörg

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #4

The default master node timeout for create index operation is 30 seconds. I
can't tell why a cluster change takes so long to get persisted, is it a
large cluster?

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Oliver B. Fischer) #5

No, currently a single node.

Am 31.10.13 22:01, schrieb joergprante@gmail.com:

The default master node timeout for create index operation is 30
seconds. I can't tell why a cluster change takes so long to get
persisted, is it a large cluster?

Jörg

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #6

I tested it with 0.90.5 but I had no trouble in a dev environment (single
node on Mac OS X)

curl -XDELETE 'localhost:9200/test'

curl -XPUT 'localhost:9200/test' -d '
{
"mappings" : {
"docs" : {
"properties" : {
"content" : {
"type" : "string"
}
}
}
}
}
'

curl -XPOST 'localhost:9200/_shutdown'

Server shut down immediately in 1s, and after

./bin/elastiscearch -f

I can receive the mapping

curl -XGET 'localhost:9200/test/_mapping'
{"test":{"docs":{"properties":{"content":{"type":"string"}}}}}

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Oliver B. Fischer) #7

I will try to provide an example for this problem. Ok?

Am 01.11.13 11:56, schrieb joergprante@gmail.com:

I tested it with 0.90.5 but I had no trouble in a dev environment
(single node on Mac OS X)

curl -XDELETE 'localhost:9200/test'

curl -XPUT 'localhost:9200/test' -d '
{
"mappings" : {
"docs" : {
"properties" : {
"content" : {
"type" : "string"
}
}
}
}
}
'

curl -XPOST 'localhost:9200/_shutdown'

Server shut down immediately in 1s, and after

./bin/elastiscearch -f

I can receive the mapping

curl -XGET 'localhost:9200/test/_mapping'
{"test":{"docs":{"properties":{"content":{"type":"string"}}}}}

Jörg

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Oliver B. Fischer) #8

Hello Jörg,

it seems so that this problem is somehow related to my setup. I call
cURL from Ant.

If I do the same in the shell or via script this problem does not occur.

BR

Oliver

Am 01.11.13 14:02, schrieb Oliver B. Fischer:

I will try to provide an example for this problem. Ok?

Am 01.11.13 11:56, schrieb joergprante@gmail.com:

I tested it with 0.90.5 but I had no trouble in a dev environment
(single node on Mac OS X)

curl -XDELETE 'localhost:9200/test'

curl -XPUT 'localhost:9200/test' -d '
{
"mappings" : {
"docs" : {
"properties" : {
"content" : {
"type" : "string"
}
}
}
}
}
'

curl -XPOST 'localhost:9200/_shutdown'

Server shut down immediately in 1s, and after

./bin/elastiscearch -f

I can receive the mapping

curl -XGET 'localhost:9200/test/_mapping'
{"test":{"docs":{"properties":{"content":{"type":"string"}}}}}

Jörg

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #9