Why Elasticsearch still complains about bootstrap checks failed

Installed ES 7.3.0 on Ubuntu 18.04. Was able to start it in development mode. Now I want to connect to ES remotely from another machine, so I changed the configuration in elasticsearch.yml and tried to start it in production mode (although there's still only one ES machine). Below is my elasticsearch.yml file:

However, everytime after I run the 'sudo systemctl start elasticsearch.service' command, the elasticsearch gave me this warning "the default discovery settings are unsuitable for production use: at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured".

As you can see in the first image, I do configure the cluster.initial_master_nodes correctly. So what did I miss here?

---Updates------------------------------------------------------------------------------------------------------------------------
I just realized that no matter how many times I tried to restart the elasticsearch service, for some reason it is not updating the log file. As you can see the timestamp for the last log is 2019-08-10, which is yesterday. I am pretty sure I restarted the service this morning several times and today is 2019-08-11. P.S. I am in UTC-8 timezone.

please do not post images, but only text - as this image is barely readable on bigger monitors.

try stopping the service first or run restart and then check if the logfile shows any new entries.