Why there can't change default cluster name in es5?


(Elkan1788) #1

Today I were try to deploy elasticsearch5 in my test server, and then update the default yml configure file about the cluster name toes5 , but it's so strange after restart elasticsearch5 service. There still show up default cluster name is elasticsearch, but the log file name had rename to es5.log. So is there any wrong in my settings?

Note:

elasticsearch.yml

# ======================== Elasticsearch Configuration =========================
#
# NOTE: Elasticsearch comes with reasonable defaults for most settings.
#       Before you set out to tweak and tune the configuration, make sure you
#       understand what are you trying to accomplish and the consequences.
#
# The primary way of configuring a node is via this file. This template lists
# the most important settings you may want to configure for a production cluster.
#
# Please see the documentation for further information on configuration options:
# <http://www.elastic.co/guide/en/elasticsearch/reference/current/setup-configuration.html>
#
# ---------------------------------- Cluster -----------------------------------
#
# Use a descriptive name for your cluster:
#

cluster.name: es5

#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node:
#
node.name: master01

#
# Add custom attributes to the node:
#
# node.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
path.data: /data/elastic


#
# Path to log files:
#
path.logs: /usr/local/elastic/elasticsearch-5.0.0-alpha5/logs

#
# ----------------------------------- Memory -----------------------------------
#
# Lock the memory on startup:
#
# bootstrap.memory_lock: true
#
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#
# ---------------------------------- Network -----------------------------------
#
# Set the bind address to a specific IP (IPv4 or IPv6):
#
# network.host: 192.168.0.1
#
# Set a custom port for HTTP:
#
http.port: 9200

transport.tcp.port: 9300
transport.tcp.compress: true

elasticearch http info:

{
  "name": "Reb-PRr",
  "cluster_name": "elasticsearch",
  "version": {
    "number": "5.0.0-alpha5",
    "build_hash": "d327dd4",
    "build_date": "2016-08-04T08:59:39.568Z",
    "build_snapshot": false,
    "lucene_version": "6.1.0"
  },
  "tagline": "You Know, for Search"
}

(Daniel Mitterdorfer) #2

Hi @elkan1788,

I just tried to do the same with Elasticsearch 5.0.0-alpha5 and it worked fine for me.

Just a couple of questions:

  • Are you sure you hit the correct Elasticsearch instance?
  • Did you restart Elasticsearch after you've changed the configuration file?

Daniel


(Elkan1788) #3

Sorry forgot reply you answer. There seem some lazy execute after change settings. The next time when I restart ES service it worked fine. Thanks.


(Daniel Mitterdorfer) #4

Hi @elkan1788,

no worries, that happens. :slight_smile:

You're right: You need to restart Elasticsearch after the change because you cannot change the name of a running cluster.

Daniel


(system) #5