WMS of a local area in Kibana


(Francisco Gutierres) #1

Hi all,

If possible I need a urgent help.

I created a WMS service (image/png) of a local area but in Kibana appears very small compared to geopoints.

Is possible to adjust the visualization scheme of Kibana to observe the WMS and the geopoints correctly?

Thank you veru much,

Best regards,

Francisco Gutierres


(Thomas Neirynck) #2

Hi FGutierres,

Do you mean that the WMS is rendered at the incorrect location, or that the Dot-sizes of the map are too big compared to your WMS?

Could you also share a screenshot of the map in Kibana, and if possible provide a link to your WMS service?

thanks,


(Francisco Gutierres) #3

Hi Thomasneirynck,

Thank you very much.

Yes the the Dot-sizes of the map are too big compared to my WMS. Share with you the screenshot of the map in kibana.

The link of the WMS is:

http://localhost:8080/geoserver/wms
Smartretail:SupermarketSmartRetail
1.1.1
image/png

Best regards,

Francisco


(Thomas Neirynck) #4

Hi Francisco,

I can't reach that WMS link, my localhost is not your localhost :wink:

I think you are hitting the zoom-in limit of Kibana. The default Kibana map only zooms in 10 levels. You can change the min and max-zoom settings in the kibana.yml settings (https://www.elastic.co/guide/en/kibana/current/kibana-server-properties.html#tilemap-settings). When you set it to a max zoom level that corresponds to your data, you can zoom in all the way to your local area on the WMS map. You will also see that the dots will start to split up as you zoom in.

The relevant thing to note here is that Kibana shows aggregations on a map (each dot correspond to an aggregation of multiple documents in your index), instead of the location of an individual document. So that big dot actually represents an aggregation value of all documents on the map.

thanks,


(Francisco Gutierres) #5

Dear Thomas,

Thank you very much. I will try to change the kibana.yml settings.

Best regards,

Francisco


(Francisco Gutierres) #6

Dear Thomas,

Please you can explain how to change the kibana.yml settings?

Best regards,

Francisco


(Thomas Neirynck) #7

Hi Francisco,

In the Kibana release, go to config/kibana.yml.

That is a text file. In there, add a new entry that specifies the map options.

e.g.:

tilemap.url: "http://your.preferred.mapservice/{z}/{y}/{x}"
tilemap.options.minZoom: 1
tilemap.options.maxZoom: 20

Then, restart Kibana (bin/kibana).

thanks,


(system) #8