X of y shards failed

Type: es_rejected_execution_exception

Reason: rejected execution of org.Elasticsearch.common.util.concurrent.TimedRunnable@5ec3e8 on QueueResizingEsThreadPoolExecutor

I had monitored the CPU and RAM and all the metrics is ok.
also tried to reroute the shard to another node.

still get the same error -
ES and Kibana - V 7.13.2

Can you share more of this error please.

What is the output from the _cluster/stats?pretty&human API?

any updates ?
what could be the problem?
what do I have to check ?

Are you using Monitoring for your cluster? It looks like you are getting overloads on your node(s) and filling threadpools.

How are you indexing data into Elasticsearch?
What do your Elasticsearch logs show?

yes I have a monitoring process,
indexing - using Logstash
Logs - looks ok nothing relevant I think.

any updates ?

Unfortunately we need more information here.

We need to see the complete error you are getting.
We'd need to see your Elasticsearch logs from around the time of this error as well.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.