X-pack basic license can not be installed from Kabana


(Abdul Qayyum) #1

I have downloaded x-pack basic license and tried to install using kibana. It gives authentication error:

{
  "error": {
"root_cause": [
  {
    "type": "security_exception",
    "reason": "action [cluster:admin/xpack/license/put] is unauthorized for user [kibana]"
  }
],
"type": "security_exception",
"reason": "action [cluster:admin/xpack/license/put] is unauthorized for user [kibana]"
  },
  "status": 403
}

my command was:

PUT /_xpack/license 
{..my license..}

So please tell me how to solve it. I am on windows machine and do not have curl even gc installed.


(Abdul Qayyum) #2

Here is the update:
As there was no help so downloaded curl at last but here is the error I am facing now

"Content-Type header [application/x-www-form-urlencoded] is not support


(David Pilato) #3

You need to give the content type as explained in the guide: https://www.elastic.co/guide/en/x-pack/current/installing-license.html


(Abdul Qayyum) #4

After installation of curl and using your link here is the new problem:

{"error":{"root_cause":[{"type":"security_exception","reason":"failed to authent
icate user [elastic]","header":{"WWW-Authenticate":"Basic realm="security" cha
rset="UTF-8""}}],"type":"security_exception","reason":"failed to authenticate
user [elastic]","header":{"WWW-Authenticate":"Basic realm="security" charset=
"UTF-8""}},"status":401}

I am running cURL from c:\Windows\System32 as cURL is installed there. but my elastic search is in D: so is this may be the problem?


(Abdul Qayyum) #5

Ok my bad, I was giving system password instead. Now all previous problem are solved but it is asking for acknowledgement that I will be able to do easily I think. thanks


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.