X-pack basic


(GambitK) #1

I've recently registered for a basic license of x-pack and tried installing it without luck.
I only want the kibana UI feature for logstash that's available in the basic license. I don't want authentication. Is it possible to install x-pack without the authentication feature?


(David Pilato) #2

I moved your question to #x-pack

Sure. You can always manually disable security. See https://www.elastic.co/guide/en/elasticsearch/reference/6.0/security-settings.html#general-security-settings


(Tim Vernum) #3

Can you provide more details? If you had problems installing the licence, we can help with that.


(GambitK) #4

Thanks for the reply, I manually disabled security and was able to install the license.
Thank you.


(Manya12) #5

Hi @GambitK
I am also trying to use elasticsearch image with basic x-pack enabled.
I am creating my elasticsearch cluster and deploying everything using kubernetes.
After installation of all the nodes, it prompts me for username and password for API calls.
I need to create password for default user.
How to create password for elastic user?


(Tim Vernum) #6

If you want to use the basic x-pack license (which includes monitoring, but not security) then the easiest path forward it to simply disable security so you can install the license.

Add

xpack.security.enabled: false

to your config/elasticsearch.yml file (on every node).


(Manya12) #7

Hi @TimV
Thanks for response!
It worked for me, it is not prompting for username and password but though i have used the docker image docker.elastic.co/elasticsearch/elasticsearch:6.0.0, to use x-pack with basic lisence.
I got x-pack with platinum licence with trial version of 1 month and i want basic licence for 1 year only.


(Tim Vernum) #8

It sounds like something went wrong with your docker setup - that image should configure X-Pack with a basic license.

What does your Dockerfile look like?


(Manya12) #10

@TimV
My dockerfile looks like following:
FROM docker.elastic.co/elasticsearch/elasticsearch:6.0.0
COPY elasticsearch.yml /usr/share/elasticsearch/config/

ENV ES_JAVA_OPTS "-Xms512m -Xmx512m"
ENV CLUSTER_NAME elasticsearch-default
ENV NODE_MASTER true
ENV NODE_DATA true
ENV NODE_INGEST true
ENV HTTP_ENABLE true
ENV NETWORK_HOST site
ENV HTTP_CORS_ENABLE true
ENV HTTP_CORS_ALLOW_ORIGIN *
ENV NUMBER_OF_MASTERS 1
ENV MAX_LOCAL_STORAGE_NODES 1
ENV SHARD_ALLOCATION_AWARENESS ""
ENV SHARD_ALLOCATION_AWARENESS_ATTR ""
ENV MEMORY_LOCK true
ENV DISCOVERY_SERVICE elasticsearch-discovery
ENV MEMORY_LOCK false

VOLUME ["/data"]


(Tim Vernum) #11

This is the problem.
You are overwriting the container's elasticsearch.yml with your own. The elastic provided containers have various configuration settings inside the elasticsearch.yml that control their behaviour, including the set of features that are enabled.

If you want to use your own elasticsearch.yml, then you should enable and disable the features that you intend to use.

The elastic provided "basic" flavour docker image only includes a 30 day license. If you want a 1 year license then you need to register at https://register.elastic.co/
You can apply that basic license to any cluster that has x-pack installed (regardless of whether it came from the "basic" or "platinum" flavoured image).


(Manya12) #12

Blockquote
I have registered on https://register.elastic.co/ and has obtained my free basic licence for an year.
How to use that license with my es-cluster which is deployeed on kubernetes using basic docker image of elasticsearch.
As after obtaining licence, it requires to be updated, which is referred here
https://www.elastic.co/guide/en/x-pack/current/installing-license.html


(Tim Vernum) #13

I'm sorry I don't understand the question - the page you linked to explains how to install the licence. Is something not working?


(Manya12) #14

I have the licence with me, and i need to use it in my elasticsearch cluster running in kubernetes. How can i do it?


(Tim Vernum) #15

The link you posted has a curl command for installing the licence - have you tried to use that? Is there a problem?


(Manya12) #16

@TimV
It worked for me with those curl commands.
Thanks!


(system) #17

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.