X-pack settings for x-pack features


#1

I change respective setting(s) to false, yet still seeing apps/features via Kibana

Please advise.


(Jymit Singh Khondhu) #2

Was this set on all Elasticsearch node/s? Were these node/s then restarted for this modification to propagate?


#3

all settings are Kibana's settings, not elasticsearch.

I was able to disable other apps/features without modifying any elasticsearch nodes, why not those two?


(Jymit Singh Khondhu) #4

Looking at this: https://www.elastic.co/guide/en/kibana/6.2/settings-xpack-kb.html
You are absolutely correct!

I just tested this on Stack version 6.2.3, Kibana and it worked. What version are you running?


#5

I'm running 6.2.3 as well:

# grep -Ei '(xpack.apm.ui.enabled|xpack.grokdebugger.enabled|xpack.searchprofiler.enabled)' docker-compose.override.yml 
                                - XPACK_APM_UI_ENABLED=false
                                - XPACK_GROKDEBUGGER_ENABLED=false
                                - XPACK_SEARCHPROFILER_ENABLED=false
#

(Jymit Singh Khondhu) #6

Fancy trying with:

- 'xpack.apm.ui.enabled=false'
- 'xpack.grokdebugger.enabled=false'
- 'xpack.searchprofiler.enabled=false'

#7

Okay, I still don't understand why it isn't working for me nor what can I do, to make it work...


#8

bump?


(Tim Vernum) #9

The xpack.apm.ui.enabled setting is not currently supported in the docker image. I've raised an issue to fix this.

You should get a similar result to what you're after by using xpack.apm.enabled instead.

For the GrokDebugger and SearchProfiler, can you confirm exactly what you're seeing and what you're expecting to see?
I haven't been able to reproduce your issue, and I just wanted to check we're looking at the same thing.


#10

I apologize for delay response...

APM:

Changing XPACK_APM_UI_ENABLED=false to XPACK_APM_ENABLED=false - did the trick! thanks!

Dev Tools:

# egrep -i 'xpack_(grokdebugger|searchprofiler)_enabled'  docker-compose.override.yml 
                        - XPACK_GROKDEBUGGER_ENABLED=false
                        - XPACK_SEARCHPROFILER_ENABLED=false
# 

I confirm on 6.2.4 (using Docker) Dev Tools still there, even though I set flag to false.


(system) #11

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.