XDELETE and now unable to create index pattern


(Nicolas Meriot (Slop)) #1

Hello,

I'm here because after having developped and clear all my grok filter on logstash, to have something very clear .. I've done a :
curl -XDELETE 'localhost:9200/_all'

Then a lot of errors appeared and I've decided to just delete my logstash-* index to create it again and just keep my final attributs.

The problem is now, I can't create my logstash-* index anymore with the time-based options, and I don't understand why.

I've check all my conf files and they seems ok and havn't change :frowning:


(Magnus Bäck) #2

The problem is now, I can't create my logstash-* index anymore with the time-based options, and I don't understand why.

Are you talking about the logstash-* index pattern in Kibana? Please elaborate on exactly what you're doing and what error message (or other unwanted behavior) you're getting in response.


(Nicolas Meriot (Slop)) #3

Hi @magnusbaeck, yes I'm talking about the logstash-* index pattern in Kibana.

I'm not having any error anymore, I just can't configure the index.


(Magnus Bäck) #4

I just can't configure the index.

And what does that mean?


(Nicolas Meriot (Slop)) #5

Hi,

It meens I wasn't able to create it (the button was grey), but this morning without any change it work and I can now create my logstash-* index with @timestamp field.

I don"t understand, do you know what happened ?


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.