Yarn 2 support?

Hi there,

I'm curious whether Kibana can be built with yarn 2 and, if not, whether that's on your roadmap :slight_smile:

Thanks in advance!

Hi @josephine-rueckert,

Our current supported version of yarn can be found in package.json in kibana repo. Yarn 2 may work but there is no guarantee as we have not yet evaluated it. It is also not currently on our roadmap, it may eventually be down the line though.

Thanks!
Liza

Hi Liza,

Thanks for your quick reply.

I'd like to ask you to consider evaluating this sooner than "eventually down the line", because the following issue is getting worse and worse: https://github.com/yarnpkg/yarn/issues/7521

Based on the comments of the collaborator that tried to fix that issue on yarn side, it looks like yarn does not intend to do anything about it. As using yarn 2 helps, it might make sense to look into it, I guess, but that's only my point of view :slight_smile:

Thanks for considering!

Best regards,
Josephine

Thanks Josephine,

I filed this discuss issue with the team, feel free to subscribe / comment:

Thank you very much, Liza! I subscribed the thread and am looking foward to hearing from the Kibana community :slight_smile:

1 Like