Yarn start error: Permission denied

I tried to develop kibana and run the commands in Getting started | Kibana Guide [7.14] | Elastic, when I run yarn start --run-examples the terminal threw an error:

Error: Permission denied
    at Object.open (user/git/kibana/node_modules/lmdb-store/index.js:77:7)
    at new Cache (user/git/kibana/node_modules/packages/kbn-optimizer/src/node/cache.ts:43:28)
    at Object.registerNodeAutoTranspilation (user/git/kibana/node_modules/packages/kbn-optimizer/src/node/node_auto_tranpilation.ts:136:17)
    at Object.<anonymous> (user/git/kibana/src/setup_node_env/index.js:11:27)
    at Module._compile (internal/modules/cjs/loader.js:1085:14)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1114:10)
    at Module.load (internal/modules/cjs/loader.js:950:32)
    at Function.Module._load (internal/modules/cjs/loader.js:790:14)
    at Module.require (internal/modules/cjs/loader.js:974:19)
    at require (internal/modules/cjs/helpers.js:92:18)
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

My Environment information is:

  • macos 11.3.1
  • node 14.7.3
  • yarn 1.22.10


I wasn't able to reproduce the permissions error.

Have you tried running yarn kbn clean and then rerunning yarn es-snapshot and then in a separate terminal yarn start --run-examples? Or alternatively delete the node_modules directory, then yarn kbn bootstrap?


1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.