You are not authorized to access Ingest Manager

I didn't set up a login user.

What version are you using?
How did you install it?

I use docker compose to run elasticsearch

es version: elasticsearch:8.0.0-SNAPSHOT

services:
  elasticsearch:
    image: elasticsearch:8.0.0-SNAPSHOT
    container_name: elasticsearch-docker
    environment:
      - node.name=es-docker
      - cluster.name=es-single-node
      - discovery.type=single-node
      - bootstrap.memory_lock=false
      - "ES_JAVA_OPTS=-Xms2G -Xmx2G"
    ulimits:
      memlock:
        soft: -1
        hard: -1
    volumes:
      - /home/esdata/:/usr/share/elasticsearch/data
    ports:
      - 9200:9200
      - 9300:9300
    networks:
      - elastic

8.X is unreleased, is there a reason you are running that?

I think there should be no external reason.

Not sure what you mean by that sorry.

I would suggest you run 7.9.1, as it's our newest, supported release.

I downloaded version 7.9.1 and still has this problem

What user did you login as?
If you didn't login as a user, exactly what version and what distribution did you install?

I don't have enable user authentication.
The installation method I used was mentioned earlier(docker-compose).

Ingest manager requires that security is enabled. You cannot use Ingest Manager unless you turn security on.

1 Like