Ingest Manager requires superuser privileges

Hi,

I can't open the tab Ingest Manager.
Message appears
obraz

what could be causing this behavior?

It says you require to have superuser privileges.

Is the user you're logged in are in the superuser role?

Ingest Manager is currently only available to users with the superuser role.

Kibana didn't require me to log in.
I'm starting kibana service as root user on localhost.

sudo /bin/systemctl daemon-reload
sudo /bin/systemctl enable elasticsearch.service
sudo /bin/systemctl start elasticsearch.service

There's an issue in kibana git that is similar to what you're facing right now.

In order for Kibana Ingest Manager to work, you will require superuser role.

And in order for you to have superuser role, you will have to:

  1. Enable Elasticsearch security features
  2. Create passwords for built-in users
  3. Add the built-in user to Kibana

Hope this can help with your issue.