Unable to initialize Ingest Manager behind proxy

Hi,
I tried to use new beta Ingest Manager functionality.
However, I got this error in Kibana when launching it:

Unable to initialize Ingest Manager
Error connecting to package registry at https://epr-7-9.elastic.co/search?package=endpoint&internal=true&experimental=true&kibana.version=7.9.0: request to https://epr-7-9.elastic.co/search?package=endpoint&internal=true&experimental=true&kibana.version=7.9.0 failed, reason: getaddrinfo ENOTFOUND epr-7-9.elastic.co epr-7-9.elastic.co:443

The VM is behind a Proxy, and using a command line it is possible to fetch data, using curl:
curl -O "https://epr-7-9.elastic.co/search?package=system&internal=true&experimental=true&kibana.version=7.9.0"
I noticed there isn't any documented way to specify a connection proxy in Kibana. Any way to solve it?
Thank you,
Dario

Hi @iorfix Unfortunately, our current beta does not support a proxy. We have an option issue here discussion proxy support, best chime in here: https://github.com/elastic/kibana/issues/70710

+1 if this is solved. We have multiple customers and also hosting a multi tenant platform. All behind proxies :slight_smile:

I'm a Heroku customer and I think I'm seeing this error after upgrading my Elastic resource. APM is failing with an error suggesting I have no ingest nodes (though my primary node is configured for ingest), and the Ingest Management screen in Kibana is displaying the error described above.

@aewing I think the two errors are not related. Could you create a separate topic for the "no ingest node" part?

For your Heroku setup, I'm curious if you have put a proxy in front or if this just comes by default?