2 Errors with Elasticsearch

When I open Kibana by searching for my IP in my browser, I get the
following 2 errors. Would anyone happen to have any advice on how to fix
these errors? I already updated Elasticsearch to its latest version
(elasticsearch-1.4.2, kibana-4.0.1-linux-x64, logstash-1.4.2):

- Upgrade Required Your version of Elasticsearch is too old. Kibana
requires Elasticsearch 0.90.9 or above.

- Error Could not reach http://localhost:9200/_nodes. If you are using a
proxy, ensure it is configured correctly

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f8c26829-892d-497c-85fd-19d07638009c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

It'd because you are using the node protocol with LS, change to the http
protocol and you will be ok. See
http://logstash.net/docs/1.4.2/outputs/elasticsearch#protocol

On 7 April 2015 at 01:05, kelnrluierhfeulne dmch12345@gmail.com wrote:

When I open Kibana by searching for my IP in my browser, I get the
following 2 errors. Would anyone happen to have any advice on how to fix
these errors? I already updated Elasticsearch to its latest version
(elasticsearch-1.4.2, kibana-4.0.1-linux-x64, logstash-1.4.2):

- Upgrade Required Your version of Elasticsearch is too old. Kibana
requires Elasticsearch 0.90.9 or above.

- Error Could not reach http://localhost:9200/_nodes. If you are using
a proxy, ensure it is configured correctly

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f8c26829-892d-497c-85fd-19d07638009c%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/f8c26829-892d-497c-85fd-19d07638009c%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9-cnyN%3DjcUOwdDQdjUNyu5yvsNekF-%3Du4ariDWKq2qEQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Thanks for the advice. I think that should do the trick but I cannot figure
out how to change to the http protocol. I looked on the link you attached
and online. Would you happen to know how to go about changing to the http
protocol?
Thank you so much

On Monday, April 6, 2015 at 5:07:24 PM UTC-4, Mark Walkom wrote:

It'd because you are using the node protocol with LS, change to the http
protocol and you will be ok. See
http://logstash.net/docs/1.4.2/outputs/elasticsearch#protocol

On 7 April 2015 at 01:05, kelnrluierhfeulne <dmch...@gmail.com
<javascript:>> wrote:

When I open Kibana by searching for my IP in my browser, I get the
following 2 errors. Would anyone happen to have any advice on how to fix
these errors? I already updated Elasticsearch to its latest version
(elasticsearch-1.4.2, kibana-4.0.1-linux-x64, logstash-1.4.2):

- Upgrade Required Your version of Elasticsearch is too old. Kibana
requires Elasticsearch 0.90.9 or above.

- Error Could not reach http://localhost:9200/_nodes. If you are using
a proxy, ensure it is configured correctly

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f8c26829-892d-497c-85fd-19d07638009c%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/f8c26829-892d-497c-85fd-19d07638009c%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/794e1e80-9742-4a9b-bb6c-d2c59181df6e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

If you read the whole page it explains it.

protocol http://logstash.net/docs/1.4.2/outputs/elasticsearch#protocol => ... # string, one of ["node", "transport", "http"] (optional)

On 8 April 2015 at 04:09, kelnrluierhfeulne dmch12345@gmail.com wrote:

Thanks for the advice. I think that should do the trick but I cannot
figure out how to change to the http protocol. I looked on the link you
attached and online. Would you happen to know how to go about changing to
the http protocol?
Thank you so much

On Monday, April 6, 2015 at 5:07:24 PM UTC-4, Mark Walkom wrote:

It'd because you are using the node protocol with LS, change to the http
protocol and you will be ok. See http://logstash.net/docs/1.4.
2/outputs/elasticsearch#protocol

On 7 April 2015 at 01:05, kelnrluierhfeulne dmch...@gmail.com wrote:

When I open Kibana by searching for my IP in my browser, I get the
following 2 errors. Would anyone happen to have any advice on how to fix
these errors? I already updated Elasticsearch to its latest version
(elasticsearch-1.4.2, kibana-4.0.1-linux-x64, logstash-1.4.2):

- Upgrade Required Your version of Elasticsearch is too old. Kibana
requires Elasticsearch 0.90.9 or above.

- Error Could not reach http://localhost:9200/_nodes. If you are
using a proxy, ensure it is configured correctly

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/f8c26829-892d-497c-85fd-19d07638009c%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/f8c26829-892d-497c-85fd-19d07638009c%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/794e1e80-9742-4a9b-bb6c-d2c59181df6e%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/794e1e80-9742-4a9b-bb6c-d2c59181df6e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9t0qMzK3YVUcDV7sxYrwarPGj-AJaPWO8S%2BiQ09xeQVw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

On Monday, April 06, 2015 at 17:05 CEST,
kelnrluierhfeulne dmch12345@gmail.com wrote:

When I open Kibana by searching for my IP in my browser, I get the
following 2 errors. Would anyone happen to have any advice on how to
fix these errors? I already updated Elasticsearch to its latest version
(elasticsearch-1.4.2, kibana-4.0.1-linux-x64, logstash-1.4.2):

(1.4.2 isn't the latest version of Elasticsearch, not even in
the 1.4.x series.)

  • Upgrade Required Your version of Elasticsearch is too old. Kibana
    requires Elasticsearch 0.90.9 or above.
  • Error Could not reach http://localhost:9200/_nodes. If you are using
    a proxy, ensure it is configured correctly

Are you sure this is Kibana 4? AFAIK that error message only exists in
Kibana 3

--
Magnus Bäck | Software Engineer, Development Tools
magnus.back@sonymobile.com | Sony Mobile Communications

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/20150408071351.GC3078%40seldlx20533.corpusers.net.
For more options, visit https://groups.google.com/d/optout.

On Wednesday, April 08, 2015 at 09:13 CEST,
Magnus Bäck magnus.back@sonymobile.com wrote:

On Monday, April 06, 2015 at 17:05 CEST,
kelnrluierhfeulne dmch12345@gmail.com wrote:

[...]

  • Upgrade Required Your version of Elasticsearch is too old. Kibana
    requires Elasticsearch 0.90.9 or above.
  • Error Could not reach http://localhost:9200/_nodes. If you are
    using a proxy, ensure it is configured correctly

Are you sure this is Kibana 4? AFAIK that error message only exists
in Kibana 3

Oh, and if it indeed is Kibana 3 I responded to the same question on
logstash-users yesterday.

https://groups.google.com/d/msg/logstash-users/rFtu_WBK3Hk/TwNbAFuV0J0J

Please don't post the same question to multiple lists.

--
Magnus Bäck | Software Engineer, Development Tools
magnus.back@sonymobile.com | Sony Mobile Communications

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/20150408071918.GA4886%40seldlx20533.corpusers.net.
For more options, visit https://groups.google.com/d/optout.