Kibana error when The GUI popped up


(roger vaede) #1

I tried to bring up the Kibana GUI. IP:5601 this error appeared:

This version of Kibana requires Elasticsearch ^2.2.0 on all nodes. I found the following incompatible nodes in your cluster: Elasticsearch v1.3.9 @ inet[localhost/127.0.0.1:9200] (172.22.xx.xx)

I have installed kibana-4.4 and elasticsearch-2.2

Thanks


(Matt Bargar) #2

Could you navigate to 127.0.0.1:9200 in your browser and paste the output here? I don't think we've had reports of Kibana incorrectly identifying Elasticsearch versions in the past.


(Mark Walkom) #3

Are you using an old version of Logstash with the transport protocol?


(roger vaede) #4

NO page is displayed


(roger vaede) #5

I am using this version: logstash-2.2


(Matt Bargar) #6

Where is your elasticsearch instance running? I thought it was local based on the error in the original post. What happens if you try to to load the url configured in kibana.yml as the elasticsearch host in your web browser? You should get a status page including the elasticsearch version number when sending a simple GET request to ES.


(roger vaede) #7

The elasticsearch is running on the master server.
I tried opening the GUI 127.0.0.0:9200 and localhost:9200 and 172.22.17.62:9200
Page cannot be displayed.

Here is the kibana.yml file, is there anything incorrect in the file?

Kibana is served by a back end server. This controls which port to use.

server.port: 5601

The host to bind the server to.

server.host: "172.22.17.62"

If you are running kibana behind a proxy, and want to mount it at a path,

specify that path here. The basePath can't end in a slash.

server.basePath: ""

The maximum payload size in bytes on incoming server requests.

server.maxPayloadBytes: 1048576

The Elasticsearch instance to use for all your queries.

elasticsearch.url: "http://localhost:9200"

elasticsearch.url: "http://localhost:9200"

preserve_elasticsearch_host true will send the hostname specified in elasticsearch. If you set it to false,

then the host you use to connect to this Kibana instance will be sent.

elasticsearch.preserveHost: true

Kibana uses an index in Elasticsearch to store saved searches, visualizations

and dashboards. It will create a new index if it doesn't already exist.

kibana.index: ".kibana"

The default application to load.

kibana.defaultAppId: "discover"

If your Elasticsearch is protected with basic auth, these are the user credentials

used by the Kibana server to perform maintenance on the kibana_index at startup. Your Kibana

users will still need to authenticate with Elasticsearch (which is proxied through

the Kibana server)

elasticsearch.username: "user"

"/opt/kibana/config/kibana.yml"

elasticsearch.password: "pass"

SSL for outgoing requests from the Kibana Server to the browser (PEM formatted)

server.ssl.cert: /path/to/your/server.crt

server.ssl.key: /path/to/your/server.key

Optional setting to validate that your Elasticsearch backend uses the same key files (PEM formatted)

elasticsearch.ssl.cert: /path/to/your/client.crt

elasticsearch.ssl.key: /path/to/your/client.key

If you need to provide a CA certificate for your Elasticsearch instance, put

the path of the pem file here.

elasticsearch.ssl.ca: /path/to/your/CA.pem

Set to false to have a complete disregard for the validity of the SSL

certificate.

elasticsearch.ssl.verify: true

Time in milliseconds to wait for elasticsearch to respond to pings, defaults to

request_timeout setting

elasticsearch.pingTimeout: 1500

Time in milliseconds to wait for responses from the back end or elasticsearch.

This must be > 0

elasticsearch.requestTimeout: 300000

Time in milliseconds for Elasticsearch to wait for responses from shards.

Set to 0 to disable.

elasticsearch.shardTimeout: 0


(Matt Bargar) #8

Could you post that config to a gist or a pastebin so it's easier to read (or at least wrap it in preformatted text tags using the </> icon in the comment editor?

It looks like you need update

elasticsearch.url: "http://localhost:9200"

If elasticsearch isn't running at localhost:9200, you need to update that config option to whatever address elasticsearch is running at.


(nader) #9

this is the resullt of navigation to 127.0.0.1:9200
{
"status" : 200,
"name" : "Death's Head",
"version" : {
"number" : "1.1.1",
"build_hash" : "f1585f096d3f3985e73456debdc1a0745f512bbc",
"build_timestamp" : "2014-04-16T14:27:12Z",
"build_snapshot" : false,
"lucene_version" : "4.7"
},
"tagline" : "You Know, for Search"
}


(Matt Bargar) #10

There's your problem, you're running a very old version of Elasticsearch.


(roger vaede) #11

What I did is remove the old version of elasticsearch and resinstalled the new version using yum.
Now I am not able to start elasticsearch. Here is the error:

[root@cba-vml-ops-elk01 ~]# service elasticsearch status
elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled)
Active: failed (Result: exit-code) since Fri 2016-03-18 08:43:24 EDT; 5s ago
Docs: http://www.elastic.co
Process: 17278 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -Des.pidfile=${PID_DIR}/elasticsearch.pid -Des.default.path.home=${ES_HOME} -Des.default.path.logs=${LOG_DIR} -Des.default.path.data=${DATA_DIR} -Des.default.path.conf=${CONF_DIR} (code=exited, status=1/FAILURE)
Process: 17276 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)
Main PID: 17278 (code=exited, status=1/FAILURE)

Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:169)
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.node.Node.(Node.java:153)
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.node.Node.(Node.java:128)
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.node.NodeBuilder.build(NodeBuilder.java:145)
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:178)
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:285)
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)
Mar 18 08:43:24 cba-vml-ops-elk01 elasticsearch[17278]: Refer to the log for complete error details.
Mar 18 08:43:24 cba-vml-ops-elk01 systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE
Mar 18 08:43:24 cba-vml-ops-elk01 systemd[1]: Unit elasticsearch.service entered failed state.


(roger vaede) #12

The problem with the elasticsearch was permissions to create a node. I fixed that.
Elasticsearch started properly. I was able to bring up the Kibana GUI when I reinstalled the newer version of elasticsearch. Thank you all for your help.


(Mayank Kakoriya) #13

{
"name" : "node-1",
"cluster_name" : "my-application",
"cluster_uuid" : "_zHJ37pQS6-_xPmz1P5Vfg",
"version" : {
"number" : "5.1.2",
"build_hash" : "c8c4c16",
"build_date" : "2017-01-11T20:18:39.146Z",
"build_snapshot" : false,
"lucene_version" : "6.3.0"
},
"tagline" : "You Know, for Search"
}

i have 5.1.2 version of ES but i'm still getting the same error.

This version of Kibana requires Elasticsearch ^2.3.0 on all nodes. I found the following incompatible nodes in your cluster: Elasticsearch v5.1.2 @ undefined (10.10.10.72)


(Christian Dahlqvist) #14

Please open a new thread for your issue.


(Younes) #15

Hello,

I am getting the same error.

When I go to http://localhost:9200/ , here's what I get :

{
  "name" : "K0r0l9M",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "-Uqd4hpPTpyvHBM9Y0hUlw",
  "version" : {
    "number" : "5.3.0",
    "build_hash" : "3adb13b",
    "build_date" : "2017-03-23T03:31:50.652Z",
    "build_snapshot" : false,
    "lucene_version" : "6.4.1"
  },
  "tagline" : "You Know, for Search"
}

Yet, when I go to Kibana, here's what it shows :

plugin:elasticsearch : This version of Kibana requires Elasticsearch ^2.2.0 on all nodes. I found the following incompatible nodes in your cluster: Elasticsearch v5.3.0 @ undefined (127.0.0.1)

I have both ElasticSearch and Kibana on v5.3, why am I getting this error on Kibana ?


(system) #16