5.2 Kibana Plugin installation - Optimizations failure


(Andrew Welburn) #1

Performing a rolling upgrade from 5.1.2 to 5.2 on Ubuntu 15.10

Installation of ElasticSearch and Kibana seem successful.
I've then attempted to install the x-pack plugin for kibana:

root@devu1:/usr/share/kibana# bin/kibana-plugin remove x-pack
Unable to remove plugin because of error: "Plugin [x-pack] is not installed"
root@devu1:/usr/share/kibana# bin/kibana-plugin install x-pack
Attempting to transfer from x-pack
Attempting to transfer from https://artifacts.elastic.co/downloads/kibana-plugins/x-pack/x-pack-5.2.0.zip
Transferring 108043702 bytes....................
Transfer complete
Retrieving metadata from plugin archive
Extracting plugin archive
Extraction complete
Optimizing and caching browser bundles...
Plugin installation was unsuccessful due to error "Optimizations failure.

ERROR in ./src/core_plugins/kibana/public/dashboard/styles/main.less
Module build failed: ModuleBuildError: Module build failed: TypeError: postcss.plugin is not a function
    at Object.<anonymous> (/usr/share/kibana/node_modules/autoprefixer/lib/autoprefixer.js:32:28)
    at Object.<anonymous> (/usr/share/kibana/node_modules/autoprefixer/lib/autoprefixer.js:91:4)
    at Module._compile (module.js:570:32)
    at Module._extensions..js (module.js:579:10)
    at Object.require.extensions.(anonymous function) [as .js] (/usr/share/kibana/node_modules/babel-core/lib/api/register/node.js:214:7)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/share/kibana/src/optimize/postcss.config.js:4:13)
    at Module._compile (module.js:570:32)
    at requireFromString (/usr/share/kibana/node_modules/require-from-string/index.js:27:4)
    at /usr/share/kibana/node_modules/cosmiconfig/lib/loadJs.js:11:15
    at DependenciesBlock.onModuleBuildFailed (/usr/share/kibana/node_modules/webpack/node_modules/webpack-core/lib/NormalModuleMixin.js:315:19)
    at nextLoader (/usr/share/kibana/node_modules/webpack/node_modules/webpack-core/lib/NormalModuleMixin.js:270:31)
    at /usr/share/kibana/node_modules/webpack/node_modules/webpack-core/lib/NormalModuleMixin.js:292:15
    at context.callback (/usr/share/kibana/node_modules/webpack/node_modules/webpack-core/lib/NormalModuleMixin.js:148:14)
    at /usr/share/kibana/node_modules/postcss-loader/index.js:137:13
 @ ./src/core_plugins/kibana/public/dashboard/index.js 33:0-52

Have I missed a step / dependency somewhere?


(Court Ewing) #2

What operating system are you running Kibana on and what install mechanism did you use initially (tar, rpm, deb, source)?

Also, did you stop Kibana before attempting to install x-pack? If not, can you stop the Kibana server, delete your optimize/bundles directory and optimize/.babelcache.json file, and then try to install x-pack again?


(Court Ewing) #3

Scratch the operating system question as you mentioned Ubuntu 15.10 in your post.


(Andrew Welburn) #4

Thanks Court,
I'm using the deb package, default installation locations.
I've ensured kibana is not running and deleted both the bundles directory and .babelcache.json file.

I then ran the installation command again, but I get the same error as above.

Note that what I posted previously was just one of the errors logged, but they're generally .less files throwing the same error about postcss.plugin, the stacktrace is the same.


(Lee Drengenberg) #5

When you remove x-pack, if it says it's installed or not, did you happen to check the /usr/share/kibana/plugins/ directory to see if it's empty? I would expect it would be, but wouldn't hurt to check.


(Andrew Welburn) #6

Thanks Lee,

Yes it's empty.


(Andrew Welburn) #7

Upgraded to Ubuntu 16.04.1 LTS, didn't make any difference.


(Andrew Welburn) #8

Sorted!
I ran apt-get purge kibana, installed kibana again, the x-pack plugin now installs fine.


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.