Installation of Kibana x-pack 5.2.0 failed on Ubuntu 16.04. & CentOS 7.2


(Markus Schneider) #1

Hi folks,

I have some trouble to install X-Pack 5.2.0 for Kibana 5.2.0 on Ubuntu 16.04. & CentOS 7.2
The following Error occurs when I try to install it:

./kibana-plugin install x-pack
Attempting to transfer from x-pack
Attempting to transfer from https://artifacts.elastic.co/downloads/kibana-plugins/x-pack/x-pack-5.2.0.zip
Transferring 108043702 bytes....................
Transfer complete
Retrieving metadata from plugin archive
Extracting plugin archive
Error: EPERM: operation not permitted, open '/opt/local/bin/elastic/elastic-5.2.0/kibana-5.2.0-linux-x86_64/plugins/.plugin.installing/node_modules/react/lib/ReactCompositeComponent.js'
Plugin installation was unsuccessful due to error "Error extracting plugin archive"

The folder '.plugin.installing/node_modules/react/lib/ReactCompositeComponent.js' doesn't exist
after running the install command.

I've seen some issues for the windows platform in the forum but not for linux

Any idea how to solve this?

Thx in advance

Cheers

-markus


(Mark Walkom) #2

Are you running that command as root?


(Markus Schneider) #3

The command was executed as root and normal user. But the result was the same ;(

-markus


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.