Installation of Kibana x-pack failed on windows 8.1


#1

Windows 8,1
From an cmd window with admin privilege:
bin\kibana-plugin.bat install x-pack

Fails with:
Plugin installation was unsuccessful due to error "EPERM: operation not permitte
d, rename 'C:\ElasticSearch\kibana-5.0.0-windows-x86\plugins.plugin.installing'
-> 'C:\ElasticSearch\kibana-5.0.0-windows-x86\plugins\x-pack'"

Looked for C:\ElasticSearch\kibana-5.0.0-windows-x86\plugins.plugin.installing and there is nothing there


Installation of Kibana x-pack 5.2.0 failed on Ubuntu 16.04. & CentOS 7.2
(Thomas Neirynck) #2

Hi @mmsood99,

does this occur consistently?

Do you have the same issue with installing X-plugins on ElasticSearch?


(Ashwini Srinivas) #3

Hi,
I too got the same error in kibana , but I don't have any issues with ElasticSearch.


(Rowland Swain) #4

I had the same problem on Windows 8.1 with kibana. Again no problem with xpath install into ElasticSearch. The xpath install into kibana consistently failed. Googling, others with the same problem turned off anti-virus, etc, which seemed to suggest a timing issue. So I rebooted, and tried an install with very little else running. Install worked.


(Thomas Neirynck) #5

@Rowland @Ashwini_Srinivas @mmsood99 thanks all for confirming this.

Could you please create a bug report here: https://github.com/elastic/kibana/issues/new

Problems are better followed up with a bug report than on the forum. We'll need to investigate this. thanks!


(Alex Pang) #6

I got the same problem on Windows 10 with X-pack installation on Kibana. X-Pack installed on Elasticsearch fine.


(Rowland Swain) #7

Done #9046


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.