Kibana x-pack installation fails


#1

When installing x-pack for Kibana I'll receive an error message which tells the directory named .phantom cannot be created.

Seems like this is a Windows problem since I cannot create the directory with that name even using PowerShell.

Error: EPERM: operation not permitted, mkdir 'C:\install\elasticsearch\kibana-6.1.1-windows-x86_64\kibana-6.1.1-windows-x86_64\plugins.plugin.installing\plugins\reporting.phantom'
at Error (native)
Plugin installation was unsuccessful due to error "Error extracting plugin archive"

System is Win10, 64-bit.


(Ioannis Kakavas) #2

Hello,

We have seen issues like this in the past Kibana 5 default password , Install failure on windows - EPERM: operation not permitted on windows where the AV had a lock on the file and that caused the installation to fail. Are you using an Antivirus on this system ?


#3

Yeap AV had a rule that prevented .phantom named directory to be created.

I tried without AV running at all. -> Windows does not allow that name either?? So it looks like to be windows related problem. Do you have any idea where to search this rule in Win10?


(Ioannis Kakavas) #4

In all the cases I've seen the issue was with the Antivirus and not with Windows itself. Do you still get the same exact Error message when installing the plugin with Antivirus disabled ?


#5

Yeap. The same error occurs. Maybe AV marks illegal filenames into windows itself somewhere and stopping AV does not have anything to do with it anymore. Just a guess...


#6

This one is solved. It was because AV.


(Ioannis Kakavas) #7

Glad you figured this out. For the benefit of other people having the same issue, could you mention what AV you are using and what was the final solution? Did you have to uninstall the AV software from your system entirely?


#8

We are using McAfee which is distributed by our security team and there’s a rule that prevents the file and directory creation with name .phantom.


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.