Advanced Settings - ignoreFilterIfFieldNotInIndex doesn't work on documents in the same index

Hi,
I have indexed some documents into one index. Every document has the same model:
{
"fieldA": "..",
"fieldB": "..",
...
}
I have created a visualization "Input Control" with two dropdown options list pointing only to this one index. First input control is defined on "fieldA" field, second input control is defined on "fieldB" field setting Parent control on fieldA.
When the flag courier:ignoreFilterIfFieldNotInIndex is disabled (default in Kibana), the value selected from first menu (list of fieldA) filters data inside second menu (so i have a list of fieldB values comparing only in the documents having the selected value for fieldA). This is the correct behavior.
But, if I enable courier:ignoreFilterIfFieldNotInIndex (switch to ON) and then select a value from first menu, no filter is applied and in the second menu I find all values for fieldB.
Reading the documentation, the option ignoreFilterIfFieldNotInIndex set to true permits to skip filter from a field not existing in multiple index pattern, but on same index pattern this flag should have no effect.
Here what reported in the documentation: "Set this property to true to skip filters that apply to fields that don’t exist in a visualization’s index. Useful when dashboards consist of visualizations from multiple index patterns."

Am I missing something or doing something wrong?
Thank you very much for your support
Regards,
Antonio

Am I missing something or doing something wrong?

You are not missing anything or doing anything wrong. This is a bug.

I created https://github.com/elastic/kibana/pull/36369 to address the issue

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.