Option ignoreFilterIfFieldNotInIndex breaks spatial filtering in Map visualizations


I'm currently working with some dashboards using visualizations mixing different indexes. I have activated ignoreFilterIfFieldNotInIndex in Kibana's advanced options to avoid errors caused by the mismatch of the various indexes' fields when filtering. However, activating ignoreFilterIfFieldNotInIndex seems to completely break the "Map" visualization spatial filtering (bounding box or shape), even if only one index is visualized.

Am I missing something ? Is there any work-arounds in Kibana 7.5 ?

Thank you very much

After comparing the queries sent when using spatial filtering with & without ignoreFilterIfFieldNotInIndex activated, it seems that the query with the option activated is incomplete:

Without ignoreFilterIfFieldNotInIndex :


With ignoreFilterIfFieldNotInIndex:


Hey @audeberc, I'm unable to find a work-around for the bug which you filed here: https://github.com/elastic/kibana/issues/56651.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.