All Shards are created on the a single node


(search) #1

When I create an index in my cluster, Elasticsearch is creating all shards
on the node in which I execute the index creation request. Can some help me
figure out what setting is causing this to happen? My cluster was fine a
week ago. I am doing some work and I want to know which setting might have
caused that issue.

Thanks.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/795c7a63-ddc3-4c64-8478-7874c389c1c4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Ivan Brusic) #2

Did you set a routing value?

--
Ivan

On Thu, Mar 27, 2014 at 1:37 PM, Search User feedworks@gmail.com wrote:

When I create an index in my cluster, Elasticsearch is creating all shards
on the node in which I execute the index creation request. Can some help me
figure out what setting is causing this to happen? My cluster was fine a
week ago. I am doing some work and I want to know which setting might have
caused that issue.

Thanks.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/795c7a63-ddc3-4c64-8478-7874c389c1c4%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/795c7a63-ddc3-4c64-8478-7874c389c1c4%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCM8_btq2i3U7mHNivUCnp6SNH2yLJz%2BVrRjpiyHUCxPA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(search) #3

No. I didn't set a routing value. Thanks
On Mar 27, 2014 11:19 PM, "Ivan Brusic" ivan@brusic.com wrote:

Did you set a routing value?

--
Ivan

On Thu, Mar 27, 2014 at 1:37 PM, Search User feedworks@gmail.com wrote:

When I create an index in my cluster, Elasticsearch is creating all
shards on the node in which I execute the index creation request. Can some
help me figure out what setting is causing this to happen? My cluster was
fine a week ago. I am doing some work and I want to know which setting
might have caused that issue.

Thanks.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/795c7a63-ddc3-4c64-8478-7874c389c1c4%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/795c7a63-ddc3-4c64-8478-7874c389c1c4%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/1UJBAxL5Vj4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCM8_btq2i3U7mHNivUCnp6SNH2yLJz%2BVrRjpiyHUCxPA%40mail.gmail.comhttps://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCM8_btq2i3U7mHNivUCnp6SNH2yLJz%2BVrRjpiyHUCxPA%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAAqRq4rszXkM6vmBsaENPX3z3psjNe1ojvV3P8aKRWWgexbBNQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Binh Ly-2) #4

Can you show the output of these:

curl localhost:9200/_settings?pretty

curl localhost:9200/_cluster/settings?pretty

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/093d1613-201b-49a8-81fb-c0e2aa4eb15b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5