Allow_auto_create set to false in all templates after uprgade to 8.12.0

Hi,

I have seen another "Other thread with no answer" where the "allow_auto_create" is not working properly.

In my cluster the setting is true by default:

GET _cluster/settings
{
  "persistent": {
    "action": {
      "auto_create_index": "true"
    },
    "cluster": {
      "indices": {
        "close": {
          "enable": "true"
        }
      }, ... more settings

But all my templates now have now the "allow_auto_create" set to false.
Is this a known "bug" or feature?

I also get the same error message like a component template forbids....

Will this override the settings again in the future? Or can I change it once?

Greetings
logger

Yes, it is a bug, it was introduced in this PR: Add allow auto create to index templates by Ikuni17 · Pull Request #170079 · elastic/kibana · GitHub

It was fixed in this PR: [Index Management] Fix allow_auto_create field in index template form by ElenaStoeva · Pull Request #178321 · elastic/kibana · GitHub

The fix is on 8.13.3

I had the same issue that lead to data loss as new indices were not being created, the solution in my case was to edit hundreds of templates to set allow_auto_create to true.