Elasticsearch's action.auto_create_index setting impact on Kibana

(P) #1

We are on Kibana 6.1 and ES 6.1. In one of our ES production clusters, we have action.auto_create_index setting as false. And when I try to create a new index pattern on Kibana, it throws an error saying that this particular setting is preventing Kibana from doing its job. I had to reset the setting in our cluster to be able to map the index pattern successfully.

  • Is there a way I can specify a pattern for this setting which would allow only Kibana indices to be created. Something like this: action.auto_create_index: +.kibana*
  • Apart from .kibana, does kibana create any other indices on ES?
  • If it doesn't, then after the first Kibana use (after .kibana has been created), can I go back and set my action.auto_create_index to false in my ES cluster?

Thanks for you help.

(Tyler Smalley) #2

The Kibana index is created once an object has been persisted, in your case it was the index pattern. Since you have disabled this, and the Kibana index has been successfully created, you should be able to again disable this setting. It's also possible to use a pattern based white/black list for this setting. For example action.auto_create_index: +.kibana*, -* (+ meaning allowed, and - meaning disallowed)

(P) #3

Thank you!

(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.