Apache logs using Kibana

I tried getting the Apache logs using filebeat to Elasticsearch kibana. but iam unable to get the logs. when i click on check data it shows : No data has been received from this module yet

filebeat : 7.17.0
elastisearch : 7.16.1 - Docker image
kibana : 7.16.1 - Docker Image

command used : sudo filebeat setup
Overwriting ILM policy is disabled. Set setup.ilm.overwrite: true for enabling.

Index setup finished.
Loading dashboards (Kibana must be running and reachable)
Loaded dashboards
Setting up ML using setup --machine-learning is going to be removed in 8.0.0. Please use the ML app instead.
See more: Machine Learning in the Elastic Stack [8.0] | Elastic
It is not possble to load ML jobs into an Elasticsearch 8.0.0 or newer using the Beat.
Loaded machine learning job configurations
Loaded Ingest pipelines.

After this the process exits.

1 Like

Hi @karewise_tech Welcome to the community.

That command

sudo filebeat setup

just sets up the all the assets it does not actually start the collection of

Now you actually need to run filebeat...

How did you install, tar.gz .dem or rpm Package?

See the quickstart here

DId you enable the Apache Module first before running setup? See Here for example yours would be the apache module.

Note did you setup the path the the logs correctly so that filebeat can access the apache logs? It has defaults set but if you apache logs are not in the default location it will not find them

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.